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About this guide
This Using Freeway guide will explain some of the concepts 
behind Freeway. It will introduce you to the intuitive 
interface, menus and palettes you will use to import or 
create design elements and add web functionality. 

There is also a step-by-step tutorial in which you will 
design and produce a web site in Freeway faster than you 
would ever have thought possible. You’ll see how easy it is 
to make a multi-page web site with graphics, text and links.

This guide covers the use of both Freeway Express and 
Freeway Pro. Both versions work in essentially the same 
way, but Pro includes many additional powerful features. 
Where the methods of working are substantially different 
they are highlighted in separate box panels.

Further information on working with Freeway can be 
found on the Softpress web site. 

Three movies of the tutorial found in this guide can be 
found at: http://www.softpress.com/support/tutorials.html 
where they are called “Getting Started with Freeway”. Please 
note that these movies were made using Freeway 5, but 
they are still very relevant.

System requirements
Freeway Pro and Express require an Intel Mac, and the 
minimum operating system requirement is Mac OS X 10.6 
(Snow Leopard) or higher. 

Copyright and acknowledgments

Copyright © 2008 and 2013 Softpress Systems Ltd. All rights reserved. 

The Freeway software and this documentation are copyright materials. No 

part of the Freeway software may be reproduced, transmitted, transcribed, 

stored in a retrieval system, or translated into any language, or computer 

language, in any form or by any means without the prior written permission 

of Softpress Systems Ltd. Additional copies of this guide may be made and 

distributed provided they include this copyright notice. 

Softpress Systems Ltd specifically retains title to all Freeway computer 

software. The software described in this guide is furnished under a license 

agreement and may only be installed, used, or copied in accordance with 

the terms of that agreement. 

Softpress is a trademark of Softpress Systems Ltd in the United States and 

other countries. Freeway is a trademark of Softpress Systems Ltd, which 

may be registered in some countries. Apple, Macintosh, Power Macintosh, 

the Universal logo and the Mac Logo are registered trademarks of Apple 

Computer Inc. All other product names are trademarks, or registered 

trademarks of their respective owners. 

Limitation of liability 

The information in this guide is believed to be correct as of the date of 

publication. However, our policy is one of continuous development and so 

the information in this guide is subject to change without notice, and does 

not represent a commitment on the part of Softpress Systems Ltd.

Contact details

Head Office

Softpress Systems

First Floor

25 Hanborough House

Hanborough Business Park

Witney, Oxon

OX29 8LH

Phone: 01993 882588

Fax: 01993 883970

Sales: 0800 731 3425

United States and Canada

Softpress Systems Inc.

3020 Bridgeway #408

Sausalito, CA 94965, USA
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Congratulations on choosing Freeway, the most  
design-friendly way to create web sites. Before you 
begin it is worth spending a little time making sure 
you understand how Freeway works and how you can 
get the very most from this software.

Freeway’s approach to web page and site design 
means you can concentrate on form and function, not 
spend most of your time tweaking code and worrying 
about compatibility. Because of this, if you’ve come 
from a code-based web production background—or 
even a template-bound one—you may have some 
unlearning to do. But relax, things will almost 
certainly be easier and more logical than you imagine.

The biggest thing to grasp is that Freeway is an  
HTML generator, not an editor. You use Freeway’s  
high-end layout tools to make your designs, and 
it deals with producing optimized web page code 
from your work, on demand. This means that you’ll 
never have to worry about over-manipulated layouts 
producing awkward code, a typical problem with 
visual HTML editors; the output is new every time. 
All the necessary fixes are included to help pages 
work consistently across browsers, and you’re free 
to switch your page output from different forms of 
HTML and XHTML as you prefer. On top of this, 

Freeway makes pages that validate as W3C-compliant 
code, automatically. So with those worrisome aspects 
banished, you can get on with thinking about more 
interesting matters: your web page designs.

For further details, tips and extra Freeway Actions, 
browse the Softpress KnowledgeBase at http://www.
softpress.com/kb and http://www.actionsforge.com. 
To tap into the collective experience of Freeway users 
around the world visit the lively Freewaytalk forum at  
http://freewaytalk.net/. 

Freeway delivers the design freedom of high-end 
DTP software to the world of web production, with 
intelligent features that make casual users, professional 
designers and free-thinking programmers alike smile in 
delight. Make the most of it!

Keith Martin
Senior Lecturer

London College of Communication

For some more useful tips from Keith, see Thinking  
Design on page 19.
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Softpress Systems was founded in 1993 in Oxford, 
England to address the emerging needs of professional 
publishers and designers for cross-media authoring 
tools.

Freeway is the result of those efforts. It is a web site 
development application designed from the ground up 
for people to design and assemble content for the web 
without needing to learn HTML, or indeed any code, to 
build sites of the highest quality.

Freeway uses the familiar approaches and tools seen 
in traditional desktop publishing. Simply draw boxes 
on your page, fill them with text and images, make 
links between the pages, add dynamic content or 
anything else you can think of, and then ask Freeway 
to publish and upload your web site for you. Freeway 
will write all of the code required to describe your 
vision, and the code will always be clean, efficient, and 
standards compliant. You never have to deal with the 
code unless you want to.

With its desktop publishing origins, Freeway is 
a favorite of traditional print designers looking to 
transfer their skills to the web. However, this is just one 
group within the Freeway community.

Photographers publish their portfolios online, 
businesses establish an online presence to sell their 
products, home users build web sites for their local 
clubs or organizations, or create personal web sites to 
share their thoughts and photos.

Freeway empowers everyone—design, expression, 
and commerce.

Enjoy Freeway!

Freeway Pro and Freeway Express
Freeway comes in two versions, Freeway Pro and 
Freeway Express. Freeway Express is our entry-level 
version, for people looking to create small web sites 
and who don’t need the full power of Freeway Pro. 
Freeway Pro provides many features for creating 
modern web sites not available in Freeway Express, and 
a huge number of productivity features.

Just some of the extra features in Freeway Pro at the 
time of writing include:

•	Multiple output options (HTML 4.01 Transitional and 
Strict, XHTML 1.0 Transitional and Strict, HTML5 
and XHTML5).

•	Full choice of output encodings available.
•	Complete color and text style management across 

your entire document.
•	Extended graphic import capabilities. Import 

Illustrator, Photoshop, TIFF, SVG files and many 
more.

•	Accessibility reporting.
•	Employ multiple style sheets for each document.
•	Full CSS text styling and CSS Layout.
•	Ability to specify relative and percentage positions 

and dimensions for layout items.
•	Specify padding, wrap, margin and border (HTML 

items only) separately for each side of an item.

About Softpress and Freeway
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Introduction and getting started

Installing Freeway
Installation of Freeway is as simple as opening a 
ZIP archive file then dragging both the Freeway and 
Showcase applications to your Applications folder.

To install Freeway:

1.	 If the ZIP archive file which was sent to you or 
which you downloaded has not automatically 
opened, double-click on it.

2.	 Open the unzipped folder to see the Freeway 
application icon and the Showcase application icon.

3.	 Drag both application icons into your Applications 
folder. You can do this by dragging and dropping 
them onto the Applications folder listed in the left 
hand pane of the Finder window (under Favorites) 
or by opening your Applications folder and 
dropping the application icons straight into that 
folder.

To serialize Freeway:

1.	 Launch Freeway for the first time by either double-
clicking the Freeway application icon in the 
Applications folder (or by clicking on the Freeway 
icon in your computer’s Dock).

2.	 This will display the Install dialog where you will 
see a text field where you can enter the serial 
number sent to you by Softpress. Carefully enter 
your serial number (or copy and paste it from the 
email you received, but make sure you don’t copy 
any spaces before or after) and click Activate. 

Installing and serializing Freeway

•	Advanced visual effects on your web site using 
Scriptaculous Actions.

•	Specify link styles on any CSS-positioned HTML item.
•	Link map: overview and maintenance of all the links 

in your document.
•	Multiple windows open for the same document at 

once.
•	Snapping palettes for easier workspace management.

•	Extended transformation options: Skew, Scale and 
Mirror content separately from its box.

•	Freely combine and manipulate shadows, glows and 
other graphic effects with greater control over their 
appearance.

•	Save items and pages as images.
•	Benefit from over 100 third-party Actions, or write 

your own.

! TipPlace Freeway and Showcase  
in the Dock
After first installing Freeway and Showcase you can 
speed up your workflow by placing the Freeway and 
Showcase applications in you computer’s Dock so you 
can launch it by simply clicking on its icon. To do this, 
open your Applications folder and drag the application 
files into your Dock one at a time. Move it to the 
position you want it to appear in the Dock and let go.
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3.	 If you don’t yet have a serial number because you 
want to use the free 30-day trial, click Use Trial.

4.	 If your trial period has expired and you wish to buy 
Freeway to obtain a serial number, click Buy Now.

If your computer is connected to the internet, a 
welcome screen will appear when Freeway launches 
which offers links to learning resources and other 
relevant information. If you don’t want to see this 
screen on start-up in the future, deselect the Show This 
Dialog at Startup option.
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Registering Freeway
To ensure we can offer support as efficiently as possible, 
it’s important that you register your copy of Freeway 
with Softpress.

http://www.softpress.com/support/register.html

Another advantage of registering your software is that 
you’ll be able to use the serial number retrieval facility 
on the Softpress web site (see below).

Keep your serial number safe
You should always keep your serial number safe. If you 
have bought a new computer or you have problems 
with your hard disk, you’ll need your serial number to 
reinstall Freeway.

If you’ve lost your serial number, we have a page 
on our web site which should enable you to retrieve 
it—but this facility is only available to those who have 
registered their software with Softpress. The serial 
number retrieval page is found under the “Retrieve my 
Serial Number” heading at:

http://www.softpress.com/support/

Enter the email address you used when you registered 
Freeway, and you will receive an email containing your 
serial number or numbers.
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Introduction and getting started

Using Freeway
Visit http://www.softpress.com/support/tutorials.html 
to see three movies of the tutorial contained within 
this guide. By far the best way to learn Freeway, 
however, is to build the tutorial site in Freeway as you 
read through the instructions in the tutorial section 
which starts on page 35 of this guide. The tutorial 
section also offers plenty of useful tips and other notes 
which add to your learning experience of Freeway.

If, however, you need to clarify something, or if you 
need a quick refresher, the tutorial movies are there for 
you to watch. The movies correspond to each of the 
three parts of the Using Freeway tutorial in this guide.

The KnowledgeBase
http://www.softpress.com/kb

The Softpress web site offers an extensive 
KnowledgeBase containing a wide range of information 
on every aspect of using Freeway, including technical 
notes on specific features, tutorials on how to achieve 

Freeway help and information resources

particular effects and answers to frequently asked 
questions. 

The KnowledgeBase is fully searchable and is 
extended on a regular basis to provide answers to any 
questions users ask about Freeway.

This should be the first place you go to find 
information on how to set up particular functionality 
on your Freeway page if your can’t find it in the Using 
Freeway guide or the complete Freeway 5 Reference, or if 
you have problems when building your site.

It is also the place where we will post articles 
on known issues with new versions of browser 
applications, etc.

Video tutorials
http://www.softpress.com/support/tutorials.html

There are links to many video tutorials on this page 
which show you how to do specific tasks in Freeway, 
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along with two movie tutorials which take you through 
the very basics of getting started with Freeway Express 
and Freeway Pro.

New videos are posted from time to time, so make 
sure you check back every now and again—or you can 
use the Subscribe link to be alerted when new videos 
are released, which you can then watch in iTunes.

ActionsForge
http://www.actionsforge.com

FreewayTalk.net
http://freewaytalk.net

The most vibrant, exciting place to discuss Freeway! We 
have always been keen to have our users communicate 
not just with us, but with each other too.

All Freeway Actions not offered in the core application 
as it ships are available on ActionsForge. This is the 
place to go for additional Softpress Actions (usually 
ones which offer specific functionality) and third-party 
Actions—both free and commercial. 

The version number of each Action is stated on its 
individual page.

ActionsForge is fully searchable to help you find 
suites of Actions (called ‘projects’) or individual 
Actions. If an Action is part of a project suite, all the 
Actions required for that project will be downloaded in 
the same zip file.

See the chapter on Freeway Actions in this guide to 
see how to install downloaded Actions.

FreewayTalk.net is a web-based bulletin board which 
also allows you to send and receive messages via 
email as well as through the web interface. The board 
provides space for people to talk about Freeway, as well 
as about writing Actions and developing dynamic web 
sites.

To join FreewayTalk, you’ll need to register online.

Help desk
http://www.softpress.com/kb/contact.php

Use the above URL to contact our Support Department 
for free email support for working with Freeway. You’ll 
receive a reply within one business day.
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Welcome to the World Wide Web
If you’ve surfed the web but you’ve never actually set 
up your own web site you may think that web sites are 
a bit like radio stations, and using your web browser 
to visit a web site is like tuning your radio into a 
particular radio station. 

This analogy is pretty good apart from one major 
difference; the web is totally democratic. You don’t 
need a license or any highly-specialized equipment 
to publish your site to the world—all you need is a 
computer connected to the internet and a centrally 
registered name, which costs a few dollars, so people 
know where to find you. 

The World Wide Web

How do I get on the web?
To publish your web site on the World Wide Web and 
make it available to other users you simply need to 
run a program called a web server on your computer 
and give the computer a name registered with a central 
authority so that other users can find it on the internet. 

Unless you have a permanent internet connection, 
and don’t mind leaving your computer switched on all 
the time, you will probably find it more convenient to 
have your web site hosted by a company specializing in 
this service, called an Internet Service Provider or ISP. 

If you already have an email account it probably has 
some free web space included with it, and your ISP will 
provide instructions on how to upload your web pages 
to your free web space, and tell you what name users 
will need to use to connect to it. 

If you don’t have free web space included with your 
package, or if you want extra features for your web site, 
you’ll need to pay for a “hosting” service from an ISP 
which may come in a package with a “domain name”.

The domain name is the name a visitor types into 
the web address field of a web browser to access a site. 
Domain names can have many different suffixes at the 
end of the address, such as .com, .net, .org, etc.

HTML—speaking the right language
At the heart of the web is a language called HTML, 
which stands for HyperText Markup Language. HTML 
performs two basic functions: it describes what the page 
should look like, and it provides links to other pages.
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For example, this is what the user sees: The second important part of HTML, called 

“hyperlinks”, is what makes the World Wide Web a 
web rather than just a notice board. Each page can link 
to other pages within the same web site, or to pages on 
other sites anywhere else on the web. 

Just as you don’t need to understand the internal 
codes your word processor uses to store information 
about your document, you don’t need to know HTML 
to design web pages.

What are HTTP and FTP?
These are two other terms that you might encounter, 
and it is just as well to know what they mean.

•	HTTP, or HyperText Transfer Protocol, is a set of 
conventions for transferring web pages between a 
web server and a web browser. You are reminded of 
this every time you surf the web by the “http://” that 
your web browser inserts in front of the address in 
the address bar. 

•	FTP, which stands for File Transfer Protocol, is a 
convention for transferring files over the internet 
between two computers. FTP is the standard way of 
uploading files to a web server, and is the method 
that Freeway uses to update your web site remotely 
on your ISP’s web space. 

How Freeway works
Whether you’re new to web site design, or an 
experienced designer, Freeway lets you to create 
complex sites quickly and easily with little or no 
knowledge of HTML code.

Freeway works in a very similar way to DTP 
programs, using a WYSIWYG (What You See Is What 
You Get) environment. This, along with its intuitive, 

And this is the HTML to achieve it:

The page description part of HTML consists of a series 
of statements which say things like “Put this graphic at 
the top of the page”, “Put this text below it”. When the 
browser receives the HTML it reconstructs the page that 
the designer intended. 
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user-friendly interface, lets you focus on the design 
and functionality you want to achieve without the 
distraction of having to worry about how it will be 
encoded into HTML.

Managing the names and locations of the resources 
for your site (graphics, photos, movies, etc.) is all 
taken care of by Freeway—the entire design of your 
site is contained in a single document. When you’re 
ready to view your web site, Freeway will generate the 
HTML code and resources required and place them in a 
location of your choosing. 

Importing and optimizing graphics is also handled 
seamlessly by Freeway. Rather than preparing your 
graphics in an external application before using 
them in your site, Freeway imports graphics in many 

different formats which will be converted to the 
optimum format and size when you publish your file, 
so your site will always keep browser loading times to a 
minimum.

The HTML code generated when you publish your 
Freeway file is 100% valid, meaning that your site 
should preview perfectly in different browsers while  
also ensuring that it adheres to accessibility guidelines 
for people with disabilities. Your site being valid also 
means that it should be reasonably future-proof.

Once you’ve published your file and the HTML code 
has been generated, provide Freeway with your web 
space details and it will upload your site and all its 
necessary files through FTP or you can upload your files 
manually using your preferred FTP application.

1. Gather together 
the resources for 
your web site.

2. Design and lay out your 
site in Freeway’s intuitive 
WYSIWYG environment

3. Publish your site 
and Freeway generates 

the HTML code.

4. With Freeway, 
upload your site to 

the web.

5. Visitors see your  
web site as you  

designed it.
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Tutorial

Thinking design
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With layered items in particular (which are produced 
as CSS-controlled DIVs) this can make page structures 
particularly dynamic and fluid, flexing to follow 
browser window sizes.

Type
Setting type is easy to do, but in Freeway you have two 
main choices: graphic or HTML. Graphic type—set 
in graphic boxes—is turned to bitmap images of your 
typesetting when you publish your work. HTML type is 
encoded as regular web page text. 

You have far fewer typeface choices with HTML text, 
as you are restricted to the fonts that are generally 
available on everyone’s computers. On the other hand, 
search engines ignore graphics and only read HTML 
text, so don’t set huge paragraphs as graphics—you 
may never be found! 

Use graphic type when you want a precise look for 
a headline or something to merge with an image, 
otherwise you should normally choose HTML text 
instead. Yes, this means you have fewer options for 
fine-tuning your typesetting, but that’s the way life 
is with web design. Anyway, Freeway’s CSS-based 
formatting options give you more control over regular 
HTML type than you might think …

Styles
Creating and using styles efficiently is an important 
part of modern web design, and it is a key part of how 
Freeway works. 

Design plans
Start by thinking about your overall site design plans. 
Are there parts of the layout that will be repeated across 
multiple pages? This is ideal stuff for Master Pages, one 
of the keys to working fast and efficiently in Freeway.

Set up your guides, grids, HTML text boxes and 
graphics on a master page, then make new pages from 
there and modify those as required. You can have more 
than one master page in a site, a useful trick if you 
have one layout structure for some pages and a very 
different one for others. 

But don’t worry about planning everything before 
you begin. Freeway is very forgiving, as any decent 
design-oriented tool should be.

Page sizes
Make your Freeway page widths appropriate for your 
typical audience. Something around 900 to 950 pixels 
wide is reasonable for the vast majority of web users, 
but if your normal visitor tends to use larger screens 
then try 1000 pixels or more. This doesn’t fix the 
size of the visitor’s browser window, but it does give 
you a good design foundation to help you create a 
professional, consistent set of page layouts. 

Use the Align option in the Inspector to align your 
page content to the left, center or right. Alternatively, 
leave the page alignment unset and explore linking 
the sizes and positions of boxes to the page sides, 
using the Dimensions pane of the Inspector palette. 

Thinking design by Keith Martin
Senior Lecturer, London College of Communication
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As you format text, styles are made for you 
automatically and listed ready to be applied elsewhere. 
Amend those and your text follows suit. 

You can streamline your work by making a set of 
styles first, then applying those as you go. You can 
apply custom (non-tag) styles to a container and 
affect all its contents in one stroke, then give selected 
portions of the text further styling as required. 

If you want to go further you can improve your 
search engine chances and accessibility scores by 
using traditional structural styles to control different 
elements in your layout automatically, from tag-based 
paragraph, header and list structures to object IDs and 
so on. Start by editing the ‘p’ style in the Styles  
window to control how paragraphs of text with no 
custom formatting will appear.

Graphics
Don’t spend precious design time churning out sliced-
up and web-optimized graphics before you step across 
to Freeway. As well as ready-made GIF, JPEG and PNG 
files, Freeway Pro can import your original high-
resolution images whether they’re in TIFF, PDF, SVG 
or even native Photoshop or Illustrator format. (Use 
24-bit PNG if you have Freeway Express.) If you have 
transparency in your original graphics this will be 
carried across into your Freeway designs. 

Scale, crop and stack your images, and your  
output will always be generated as a screen-resolution, 
web-optimized JPEG or GIF, or PNG if you prefer. 

If you want sliced graphics—useful for making 
rollover parts of a larger graphic, for example—then 
uncheck the Combine Graphics option in the Inspector 

palette. This produces web-ready graphics sliced along 
the uncombined item’s boundaries, without you 
having to take virtual scissors to your original images. 
Just move the object to adjust the slice.

Optimizing
Use the Inspector palette to tweak an image’s output 
format and compression levels to get the right balance 
between file size and visual quality. You can see how 
the compression controls affect the look of your 
graphics by turning on the Graphics Preview option 
in the View menu. If you have many large graphics 
in the layout this can slow things down a little, as 
Freeway reads each original image file and generates 
the final optimized web version on the fly. But don’t 
forget about this ability; you simply can’t beat seeing 
precisely how something will look right there in your 
page layout.

Code
Customizing Freeway’s output can be done using the 
wide selection of Actions, plugin-like tools that extend 
Freeway’s feature set. 

You can also add custom code to specific places in 
a layout by dropping in Markup Item objects, using 
the HTML Markup window to reach specific parts 
of the overall code structure, or by adding extended 
markup directly to elements and styles. You can even 
make your own Actions to simplify tasks, making even 
complex conditional code production a repeatable 
snap.

Thinking D
esign
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Output
Once you have some pages set up you’ll need to 
check that they look right in a browser. You can look 
at single pages in Freeway’s internal Preview, but to 
check links and all it is best to preview in a regular 
browser. Whether you’re a sucker for Safari, a Firefox 
fan or an Opera buff, you should check your pages in 
as many modern browsers as you can. (Don’t bother 
with Internet Explorer for Mac, it isn’t related to the 
Windows versions and is long dead.) Freeway makes 
pages that are generally as cross-browser-compatible as 
is sensibly possible, but some layouts simply don’t do 
so well in some browsers. Microsoft’s Internet Explorer 

6 and 7 are the biggest offenders here, so use a PC if 
one is nearby, or one of the online browser rendering 
services if one isn’t. If you have a cyber café nearby 
that can be a pleasant way around the problem.

Upload
You can use any FTP software you like to upload 
Freeway’s output to your web site, but if you do this 
with Freeway itself then your files will be managed 
for you. Items that you remove from your page will 
be deleted from the site, and so on. It may seem like a 
small thing, but it can save you a lot of head-scratching 
and wasted server space.

Th
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The main Freeway interface window

Main interface window for Freeway Express

Tool bar

Menu bar

Site Panel/
Page Panel

Actions 
palette

The 
Inspector

Page 
Mode Buttons
▲

Hyperlink box
Site 

buttons

▲▲

Page area/ 
Layout view
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Main interface window for Freeway Pro

Tool bar

Menu bar

Site Panel/
Page Panel

Actions 
palette

The 
Inspector

Page 
Mode Buttons
▲

Hyperlink box

▲

Site 
buttons

▲

Page area/ 
Layout view
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This is the drop-down menu bar which appears at 
the top of the screen on all programs running on a 
Macintosh computer.

In this guide, we don’t have the space to look at 
every menu in detail. However, the Knowledgebase on 
the Softpress site at http://www.softpress.com/kb has 
a comprehensive list of every option and submenu 
accessible from the menu bar. 

For now we’ll look at the types of function available 
from each of the menus.

Freeway menu

This is where you can set up your Preferences and hide  
or quit Freeway.

File menu

The menu for all functions to do with your main 
document, such as opening, saving, uploading, etc.  
It also contains options for importing text, graphics 
and rich media.

Edit menu

As with most Macintosh applications, this is where you 
can cut, copy and paste. For Freeway it is also where 
you can edit your URLs and resource lists, etc.

Page menu

As the name suggests, this menu is for functions which 
are page-specific, such as adding or deleting pages, 
applying a Freeway Action to a page, etc.

Item menu

The menu for item-specific functions. In here, amongst 
other things, you can lock items, bring items to the 
front or send them to the back, duplicate items, 
transform items (Pro-only) and apply item-specific 
Freeway Actions.

Style menu

This menu contains options for styling text.

Insert menu

You can insert particular types of item on your page 
from this menu. This menu is mainly used for inserting 
items into runs of text.

View menu

From this menu you can choose zoom values, toggle 
guides on and off, view invisible characters, etc.

Window menu

This menu allows you to open any of the Freeway 
palettes and switch between open document windows.

The menu bar
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The tools on the tool bar mainly allow you to create 
or edit the different types of item you work with in 
Freeway.

Back/Forward buttons
Steps between recently visited pages.

Select tool
Selects or manipulates items or text.

Zoom tool
Zooms in and out of the page area to 
change the scale of what you’re working 
on.

CSS Layout tool
When this button is on (blue), Freeway 
will always create CSS-based layout items. 
This only applies to items drawn while the 
button is on.

HTML tool
Allows you to draw an HTML item on 
your page, commonly used to contain the 
majority of the text in your web site.

Action tool
Allows you to draw a Freeway Action item 
on your page, such as a text rollover or 
navigation bar.

Graphic tool
Allows you to draw a graphic item on your 
page. An item drawn with this tool can 
contain a graphic (for example a photo) or 
graphic text.

Oval tool
Allows you to draw an oval or circular 
graphic item on your page.

Map Area tool
Allows you draw a rectangular clickable 
area on top of graphic items.

Rotate tool
Allows you to rotate a graphic item when it 
is selected on your page.

Flow tool
Links two or more HTML or graphic 
text items together so that text can flow 
between them.

The tool bar

Freeway Express 
default tool bar

Freeway Pro  
default tool bar

Pro only



26

Q
ui

ck
 T

ou
r

Browser Preview
Click on this button to preview your site in 
the browser you’ve set as the default browser. 
Click and hold to choose a different browser, 
or choose Browser Setup to select a different 
default browser or update your list of installed 
browsers.

Inspector
Displays or hides the Inspector. This is a 
context-sensitive palette which displays 
different options depending on the item 
selected.

You can customize the Freeway tool bar by adding 
optional tools you frequently use. Some optional tools 
are available from a submenu on the tool bar, but you 
can place them on the main tool bar for immediate 
use. To do this, choose Customize Toolbar... from the 

View menu and drag the tools one at a time from the 
optional tool palette to your tool bar in a similar way 
you add items to Mac OS X’s dock. Existing tools move, 
allowing you to place the new tool in the position you 
prefer.

If you want to revert to the default tool bar at any 
time, simply go back to your Customize Toolbar palette 
and drag the default tool bar into the tool bar area.

Freeway Express allows you to place an optional 
Colors tool button which shows or hides the Colors 
palette. In Freeway Pro, there is a Styles/Colors tool 
button which opens a palette listing document styles 
and colors.

Pro-only optional tools
Most of the optional tools are the same for both 
versions, but Freeway Pro also features skew and mirror 
tools.

Pro

The optional tools 
available from the 
Freeway Express 
Customize Toolbar 
palette.
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You can also see in this list whether a page or folder 
has a Freeway Action applied to it. If an Action is 
applied, a small Freeway Action cog icon appears on 
the page or folder in the list. Select the page or folder 
and look in the Actions palette to see which Action or 
Actions are applied.

The page panel
Clicking on the title bar of the 
site panel toggles the panel 
to the page panel view. This 
panel only shows the page 
you have displayed in your 
page area.

The list of items and other 
resources on your page should 
display—if not, click on the 
disclosure triangle to the left 
of the page icon. 

Like the site panel, a 
Freeway Action cog icon 
indicates which items have 
a Freeway Action applied to 
them. Select the item and 
look in the Actions palette to 
see which Action or Actions 
are applied.

The panel to the left of the page area toggles between 
the site panel and the page panel by clicking on the 
title bar which says Site or Page at the top of the list.

By default, the panel will display as the site panel.

The site panel
The site panel displays a list of all the pages and page 
folders which make up your site, with Master pages at 
the top and pages created from the Master pages below. 
Working with Master pages is covered in detail in the 
Tutorial section.

The pages in the lower part of the site panel show 
the name of the page and the 
Master it was created from.

If you make a change to 
any page of your site, a black 
dot will appear to the left of 
the page icon in the list—this 
indicates that changes have 
been made since the last time 
the site was published.

You can change the order 
that the pages appear in the 
site panel list by clicking and 
dragging them to a different 
place.

Clicking on the disclosure triangle to the left of a 
folder icon will list all the pages contained within that 
folder.

The site and page panels
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Page button will return you to the last page you were 
working on that was created by that Master.

When you click on the Preview button, your page 
will be published if any changes have been made since 
it was last published. Your page will then be previewed 
in your Freeway window by a program which is similar 
to a web browser, but with reduced functionality.

There are three page mode buttons—Master, Page 
and Preview. The first two allow you to switch quickly 
and easily between the page you’re working on and the 
Master page it was created from. This can save a lot of 
time if you have a site with multiple Master pages.

When you have a Master page displayed, the page 
rulers turn to a tinted yellow color. This alerts you to 
the fact that any changes you make to the page will be 
applied to all pages associated with that Master.

If you have a Master page displayed, clicking on the 

The page mode buttons

The hyperlink box

If you select an item on your Freeway page, the 
hyperlink box shows if it has a hyperlink applied to 
it or not. With the item or text selected, you can click 
and hold on the hyperlink box to choose from an 
existing page of your site or an external site.

Clicking on the globe to the left of the hyperlink box 
displays the “Edit Hyperlink” dialog box, which allows 
you to link to an existing internal page or an external 
page on another site. You can also choose from any of 
the standard hyperlink protocols such as an email link.

The hyperlink box and site buttons
Hyperlinks will be covered in detail in the Tutorial 

chapter.

The site buttons

At the bottom left of the interface window are the site 
buttons. The minus button lets you delete selected 
pages or folders from your site. Clicking and holding 
on the right-hand button displays a menu giving you 
options to add pages or folders, and change the view 
options for the Site/Page panel.

           Link Map
In addition to the three page mode buttons, Freeway 
Pro also has a Link Map button which, when clicked 
on, displays a graphic representation of the links in 
your site.

Pro
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A great way to save time on your project is to use 
Freeway’s contextual menus. These are menus which 
are item-specific—showing only options relevant to 
that item—and they can be accessed without needing 
to go through a bunch of menus and submenus.

Any item on your Freeway page will generate a 
contextual menu when you Control-click (or right-click 
with a two-button mouse) on the item. If nothing is 
selected on your page, the contextual menu for the 
page will display.

Contextual menus

Note: A different contextual menu will display if you 
are currently editing text inside an HTML or graphic 
item box.

The contextual menu 
displayed for a graphic item.

The contextual menu 
displayed for an 
HTML item.

The contextual menu 
displayed when editing 
HTML text.
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Like the main Freeway 
interface window, tool tips 
display if you hover your 
mouse over the Inspector tab 
bar icons.

If nothing is selected on 
your page, the Page Inspector 
window will display. Clicking 
on the first tab displays the 
page’s General settings, which 
allows you to edit the general 
configuration of the page, such 
as setting its size, giving it a 
title, choosing how it aligns in 
the browser window, etc.

With no items selected, the 
second tab displays the page’s 
Appearance settings. This icon 
shows all the options available 
to change the physical 
appearance of your page, such 
as applying a background 
color, choosing a background 
image (with positioning and 
tiling options) and what color 
the page’s hyperlinks will be.

The most common palette you’ll use in Freeway will be 
the Inspector—a powerful, context-sensitive palette 
which displays different options depending on what 
you currently have selected (HTML item, graphic item, 
text, etc.). If you have no items selected on your page, 
the Inspector gives you options for the page itself.

We don’t have room here to cover every combination 
with each type of item. However, the Inspector works 
in a logical way whatever the item, so we’ll guide you 
through the basics of the Inspector and the type of 
options for each kind of item. The Tutorial chapter will 
show you how the Inspector works in practice.

There are quite a lot of differences in the Inspector 
between Freeway Express and Pro, but the principles 
are the same for both—so feel free to experiment with 
your version to see what the Inspector lets you do.

If the Inspector is not displayed, click on 
the button on the far right-hand side of the 
main Freeway tool bar.

Click once on an item to select it, and the Inspector’s 
palette will change to show options specific only 
to that type of item. The title bar at the top of the 
Inspector displays the item type. Below this is the 
Inspector’s tab bar, which usually displays an icon for 
each of the General, Appearance 
and Output settings for that item.

The first icon of the Inspector 
tab bar—the General settings icon—displays a similar 
icon to the tool from the main Freeway tool bar you 
used to create the item on your page. This will change 
for each different item type you select.

The Inspector
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If an HTML item or graphic 
item is selected on your page, 
clicking on it again (or double-
clicking on the item if it wasn’t 
originally selected) allows you 
to enter text inside the box. 
You’ll see that the Inspector 
options have changed again 
to reflect this, and the title bar 
has changed to “Text”.

Inspector tool bar icons in Pro
Pro always displays at 
least one extra icon on the 
Inspector tool bar, the most 
common of which is the 
Style Inspector.

When editing text within 
a graphic item, another Pro-only icon is displayed. 
This is called Typography 
settings, and contains 
advanced settings for the 
currently selected font.

Pro

The next screenshot shows how the Inspector 
changes when an item is selected. The title bar has 
changed to show the item type, and the available 
options for the General settings are different to those 
in the Page Inspector window.

Although the paintbrush icon for the Appearance 
settings is the same as the icon for the same tab in the 
Page Inspector dialog, the options will be different as 
you will now see options specific only to a graphic or 
an HTML item.

In most instances, the third icon in the Inspector 
tool bar is the “Output” 
settings icon, which give 
options relating to how the 
HTML code will be generated 
for that particular item when 
it’s published. 
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There are three other palettes which make up the 
Freeway interface—the Actions palette, Colors palette 
(called Styles & Colors palette in Freeway Pro) and 
the Frames palette.

The Actions palette and Colors palette are covered 
in depth in the Tutorial chapter, along with how 
to select colors in both Express and Pro and the 
differences between the two versions.

The Frames palette gives options of how to create 
a frameset from a selection of pre-defined frameset 
layouts. If you want to find out more about creating 
and working with framesets, please refer to the Freeway 
Reference.

Other palettesOccasionally you will need 
to access options within 
panels of the Inspector 
which are not currently 
displayed. To see these 
options you will need to 
click on the disclosure 
triangle to the left of the 
section heading in the 
Inspector palette.

Although the amount of 
options may seem daunting, 
the Inspector is very 
intuitive and you will soon 
appreciate its ease of use.

The advantage of having a context-sensitive palette 
such as the Inspector is so you only need one palette 
open on your page, rather than a different palette to 
work on each type of item.

Output settings for the page in Pro
Freeway Pro offers many options for how the code will 
be written for the page. If this is applied to each Master 
page of your site, it is effectively applied for the entire 
site.

Among these extra options are the ability to choose 
the HTML/XHTML standard for the code, language 
encoding and the ability to display the code in an 
easily-readable format when you view the page source.

Pro
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We’re going to use Freeway to create a web site for a 
photographer called Maurice Cowley. This will be done 
in three stages with a separate tutorial for each stage.

Everything we do in the tutorials can be done by 
both Express and Pro users. If you’re using Freeway 
Pro, you’ll notice that there are some differences in the 
interface as the tutorial uses screenshots mainly from 
Express. Any major differences will be pointed out as 
we go.

Each tutorial is designed to take around 30 minutes if 
you follow the instructions in strict order, but feel free 
to experiment with different options available to you 
through the various menus and palettes—this really is 
one of the best ways to learn.

By the end of the third tutorial, you will have 
created a fully-functioning web site. The site you’ll 
build contains rollover navigation links, a gallery page 
with thumbnail links to larger images and many other 
features often seen on web pages. You’ll be surprised 
that such a complex site could be created in Freeway 
in such a short time, with little or no knowledge of 
HTML.

To introduce functionality in an appropriate order, 
certain aspects of the standard workflow for site 
creation have changed. We strongly advise that you 
plan a site beforehand. 

The tutorials will guide you through the key features 
of Freeway in the following stages:

Tutorial 1: Creating a new document, learning the 
structure of your site folder, adding various elements to 
your page and checking the page in Freeway’s Preview.

Tutorial 2: Creating the structure of a multi-page 
site, using Master pages for common content, adding 
links to aid the navigation throughout the site and 
previewing the site in a web browser.

Tutorial 3: Adding functionality and dynamic effects 
to your site, such as rollovers and target images, etc., by 
using Freeway’s Actions.

Note: The image resources used for these tutorials 
can be downloaded from the Softpress web site 
at http://www.softpress.com/support/ below the 
“Manuals” heading

Instructional text appears in colored, bulleted sans serif 
type (e.g. Launch Freeway. The New Document dialog 
box will be displayed). General discursive text appears 
in the standard body text serif type.

CONVENTIONS USED IN THE TUTORIALS

The following modifier keys are used in the tutorials:
The Control key—sometimes marked L.
The Option key—sometimes marked O or called Alt.
The Command key—usually marked C or P.

Where a command or menu choice is within a 
submenu, this is indicated with the “>” symbol, such as 
“Choose Item>Action>Rollover”.

Bold � Bold text within the body text identifies a name 
or label that appears on your screen (e.g. Click 
OK)

If you experience problems with this tutorial, visit  
http://www.softpress.com/support/tutorials.html where 
you’ll find three movies of this tutorial, called “Getting 
Started with Freeway”.
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Starting and saving the site
Freeway is supplied with sets of pre-built templates and 
you can choose from different types in the left-hand 
panel of the New Document window as the starting 
point for a web site.

For this tutorial we will use the blank template, 
which will give us a clean canvas on which to design a 
site from scratch.

•	Launch Freeway. The New Document dialog should 
automatically be displayed. If not, choose New… from 
the File menu.

•	Make sure General is selected in the left pane of the 
New Document dialog, select the Blank template in 
the main panel and click OK.

When starting a site with a template (including Blank), 
Freeway will immediately prompt you to save the new 
site inside a specified project folder. This ensures that 
you have the correct site structure in place before you 
start work.

•	Enter “Tutorial1” in the Save As field, and click the 
Save button.

Custom page settings
Freeway Pro, too, is supplied with templates, but also 
has the option of custom page settings which offer 
more control—such as setting the HTML level for the 
document and how file names are treated.
  You can switch to the Custom view by clicking on 
the Custom button above the main panel of the New 
Document dialog window.

Pro

IMPORTANT NOTE TO FREEWAY PRO USERS: If you’re using Freeway Pro, please make 
sure that the CSS Button on the tool bar displays as grey (off) throughout these tutorials.
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Freeway, by default, chooses to save a web site in your 
Documents folder. If you’d like to save it somewhere 
else, use the Save dialog to navigate to a new location.

A Freeway document window will be opened for you, 
titled “Tutorial1”, with a blank page showing in the 
layout or document view.

Setting page dimensions and alignment
In Freeway, setting up a page’s dimensions and how 
it aligns in the browser window are simple tasks to 
achieve using the Inspector—a powerful, context-

sensitive palette. If the Inspector isn’t open, 
click once on the button titled Inspector on 
the far right of the Freeway tool bar.

Basic concepts and terminology of the Inspector

Because the Inspector is such an important tool in 
Freeway, it’s worth taking the time here to explain how 
it works and what terminology you’ll encounter in the 
instructions of the three tutorials.

As stated earlier, the Inspector is “context-sensitive”, 
which means that the palette’s interface and options 
will change according to the type of item selected 
and, for some items, how the item is selected. With 

no item selected on your page, the Inspector will show 
the options for the current page. The content of the 
Inspector may change, but it always retains its familiar 
structure of “title bar”, “tabs” and “panels”.

At the top of the Inspector is its “title bar”. This will 
change according to the type of item you have selected 
(“HTML Item”, “Graphic Item, etc.). If you have no 
items selected, the title will display as “Page”.

Below the title bar is a row of “tabs”. Clicking once 
on a tab displays a palette of options for a particular 
kind of functionality—most commonly, the Inspector 
displays three tabs which are called “General Settings”, 
“Appearance Settings” and “Output Settings” (note that 
there are some exceptions to this).

Title bar

Tabs

Panel

The Appearance tabThe General tab The Output tab

Open panel header bar

Closed panel header bar

In Freeway Pro, there is always an extra tab called 
“Style Inspector”, which appears at the end of the row.

The icon for the first tab—called General Settings—
usually displays as the same tool bar icon for the tool 
you used to draw the item when that item is selected 
(or, if nothing is selected on the page it will display an 
icon of a page). Anything to do with an item’s name, 
size or position is applied in the General tab.

The next tab—called Appearance Settings—has 
an icon like a paintbrush (and this is why we often call 
this the “Paintbrush tab”). In the Appearance tab you 
can apply colors, borders and effects, etc.—all things to 
change an item’s appearance.

The third tab—called Output Settings—displays 
as an icon of a web browser. Options available in the 
Output tab are specific to changing things such as 
what file type will be used for an item when the file is 
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	 Note: You must type either a Return or Tab to retain 

the information entered into the field.
•	Click and hold on the popups below the W and H fields 

to choose Center in the Align pop-up and Fixed in 
the Width pop-up.

Freeway Pro users should be aware that they need to 
enter the height and width values for the page in the 
Measurements panel and not the Dimensions panel.

Setting the page background color
Selecting colors works a little differently in Freeway 
Express and Freeway Pro—so for this tutorial we’ll 
use screenshots from Express, with differences in Pro 
pointed out where applicable.

•	Select the Appearance 
tab of the Inspector then 
click and hold on the Color 
pop‑up menu to view the list 
of seven standard primary 
and secondary colors, along 
with black, white, “None” 
and “Other...”. 

•	Select Other... to open the Colors dialog (called Color 
in Pro), enter the values “204”, “255” and “204” in the 
respective Red, Green and Blue fields and click OK.

published. In Freeway Express the Output Settings tab 
does not display for the page, as only Freeway Pro has 
Output Settings options for the page itself.

Within each tab of the Inspector are “panels”, which 
are options grouped logically into specific types of 
function. Usually, at the top of each panel is a header 
bar which, when clicked, will open or close the panel.

Clicking a second time on an HTML or empty 
graphic item allows you to type text inside. When you 
do this, the Inspector’s title bar will change to “Text”. 
Also, the General Settings tab icon will change 
to a text icon and HTML items will display the 
General and Appearance tabs while graphic items 
display the General, Appearance and Output tabs.

As stated earlier, there are exceptions to the standard 
display of tabs, but none appear in the tutorials.

Setting the page dimensions and alignment

Let’s set the page dimensions to be 700 pixels square 
and center the page horizontally in the browser 
window.

•	Select the General tab of 
the Inspector by clicking 
on the page icon (see 
screenshot on the right). In 
the Measurements panel, 
enter 700 in the W field to 
give the page a width of 
700 pixels, type a Return or 
Tab to move to the H field, 
and type 700 again. It is not 
necessary to type “px” after 
the values entered in the W 
and H fields as Freeway adds 
this for you. Left: Freeway

Express
Above: Freeway
Pro
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•	There are many other ways 
to choose colors by using 
the different options in the 
color picker to choose from 
the “web-safe” color list, 
crayons, etc. (Pro users will 
need to click on the color 
swatch in the Color palette 
to enter the standard color 
picker.)  To choose a web-
safe color for example, go 
to the color picker, click on 
the third tab (called Color Palettes), choose “Web 
Safe Colors” in the Palette popup, then choose a color 
from the list or enter the color’s “hex” value (which in 
this case is CCFFCC). Click on the color in the list to 
apply it to the page and click OK. Note that Express 
users can only choose a color by its hex value if that 
color is a web-safe color.

Choosing colors in Freeway Pro
When you select Other... from the page background 
color menu, the Color dialog opens (see previous page)
which lets you choose a color by either entering a 
“hex” value (to choose from the hexadecimal palette of 
over 16 million colors) or entering an RGB value using 
the sliders or value fields for each of the Red, Green and 
Blue values.

To see the standard Mac color picker, click on the 
color swatch in the Color dialog.

Any new color chosen will appear in the Color list 
in the Inspector or in the Colors panel of the Styles 
& Colors palette (along with the name given when 
choosing the new color) as long that color is in use by 
a page background or an item. If you want the color 
to appear in the list even if it is not being used, check 
the Permanent option before clicking OK in the Color 
dialog.

Pro

Tip: Create a palette of favorite colors
Freeway Express doesn’t store permanent custom 
colors, but there is a way to store favorite colors using 
the color palette. To do this, drag a color you’ve chosen 
from the top color swatch panel into a blank thumbnail 
swatch box in the drawer at the bottom of the window. 
You can reveal more blank swatch boxes by dragging 
the drawer down.

Express

Although the color of your page in the Freeway 
interface window has changed, note that this color will 
be applied to the entire browser background and not 
just the page itself.

Adding a page background image
Much has been written about what is considered 
tasteful and appropriate when it comes to background 
graphics for a web site. Because it’s so easy to do, many 
beginners fall into the trap of using a large single 
graphic file for the entire page background (which 
can make loading times slow) or using a “tile” graphic 
which repeats over the browser background (which can 
give the page an amateurish or dated appearance).

For our page, we’ll import a small, simple yet 
effective header bar graphic which is one of the 
media files you can download from www.softpress.
com/support/index.html by using the link under the 
Manuals heading.

•	Select the Appearance tab 
of the Inspector, click on the 
Image pop-up menu and 
choose Select.... 

Navigate to the Tutorials 
folder then, from the “Tutorial1_media” folder, choose 
“header_bar.gif” and click Open.
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•	Three more options appear 

in the Inspector palette 
below the pop-up—
Horizontal, Vertical and 
Tile. These control the 
alignment of the graphic 
on your page, so choose 
“Center” for Horizontal, 
and “Top” for Vertical, 
then choose “Neither” in the 
Tile popup so the image doesn’t repeat horizontally or 
vertically.

If you choose “Tile” for either or both alignment 
options, the image repeats to fill the browser window 
horizontally, vertically or both.

Another option in this panel is “Background scrolls” 
(checked by default). Leave this checked, otherwise the 
background image will be fixed in the browser window 
while rest of the page content will scroll.

This is a good time to save our progress so far.

•	Choose Save from the File menu.

A quick word about “items”
Any box on a Freeway page is called an “item”. An item 
can contain text, a graphic, a photo, etc. or it can be a 
shape drawn on the page with one of Freeway’s tools.

As soon as an item has been created on the page, it 
is given a unique name by Freeway—by default, this 
will be “item1”, “item2”, etc. In this tutorial you’ll be 
introduced to the two main types of items you will 
work with in Freeway—HTML and graphic items.

PRO USERS: If you haven’t already done so,  
please switch off the CSS Layout button

Adding a graphic text item
One of the strengths of Freeway is its ability to create 
fully-editable graphic text on the page. Let’s create a 
graphic text heading for Maurice’s web site.

Bear in mind that graphic text is published as an 
image. This means that it won’t be indexed by search 
engines (which can affect the search rankings for your 
site) and it can cause problems for visitors who use 
accessibility aids. It’s best to use graphic text only for 
elements that must be rendered in a certain font, or for 
creating logos, etc.

•	Click once on the Graphic tool in the tool bar. 
When you move the cursor over the page in the 
layout view, you’ll see the cursor changes to a 
cross-hair. Click and hold on the page area and drag 
diagonally down to the right to draw a wide rectangle. 
Release the mouse button to finish drawing your item.

•	The item should be selected and showing the selection 
handles around the frame. If not, click once on the 
item. 

•	To position and size the item, select the General tab of 
the Inspector, and go to the Screen Measurements 
panel. If the panel is not open, click its header bar. 

Positioning items on the page in Pro
This tutorial uses positioning 
with X and Y values as they 
appear in Express. In Freeway 
Pro these are called Left Inset 
and Top Inset on the top row 
of the Dimensions panel. In 
the Size pane below are Pro’s 
Width and Height fields. 
Although we’re not using them in this tutorial, there are 
also values for “Right Inset” and “Bottom Inset” in the 
second row of Position values.

Pro
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•	Double-click in the X field (for 
Freeway Pro, see the box on 
the previous page) to select 
the current entry and type 
10px. Press Tab to move to the 
Y field, and type 50px. Press 
Tab again to move to the W 
field and type 400px, followed 
by another Tab to move to 
the H field where you should 
type 60px. Finish off by typing 
a Return or Tab to ensure 
Freeway accepts the last value.

Values given to the X and Y fields (Left Inset and Top 
Inset in Pro) refer to the position of the item’s top left 
corner in relation to the top left corner of the page. 
This means that an X value of 10 will position the top 
left corner of the item 10 pixels in from the left edge of 
the page and a Y value of 50 will position the top left 
corner 50 pixels from the top of the page.

The W and H values refer to the Width and Height of 
the item itself.

With the item positioned on the page, let’s enter 
some text. Unlike HTML text, for graphic text you 
can use any font on your computer—this is because 
Freeway creates a graphic of the text when the item is 
eventually published.

•	 If the item is selected, click on it again. If not, click on 
it twice. You’ll see a flashing text cursor inside the item 
and the Inspector’s header bar with change to “Text”. 

•	Type “mauricecowley”. Choose Edit>Select All to 
select all the text and go to the General tab of the 
Inspector. Choose “Big Caslon” from the Font menu 
and enter 60px into the Size field. Don’t forget to press 
Tab or Return to accept the value

•	Select just the letters “maurice” with the cursor, go 
to the General tab of the Inspector and click on the 
Color pop-up menu. Using the same process as before, 
select Other... from the Color pop-up menu and set 
the color with the RGB sliders (using the values 204, 
204, 204) or as a Web Safe Color (using the hex value 
of CCCCCC).

•	Now select just the letters 
“cowley” and apply the bright 
green color (which is called 
“Green” in Pro) from the 
Color menu in the Inspector.

As well as choosing fonts, sizes 
and colors, Freeway also allows 
you to add many different 
effects to graphic text and 
graphic items, such as glows, 
shadows and outlines. Effects 
can be applied in the Appearance tab of the Inspector.

There are significant differences in the way effects 
are applied in Express and Pro, so we’ll look at how to 
apply a shadow to the logo text in each version in turn.

Make sure you select the text within the item and not 
the item itself, as some effects can be applied to either 
the item box or text inside it.

Freeway Express

•	Select all the text, go to the 
Appearance tab of the Inspector 
and select the Shadow button 
(which has an icon of a letter 
“A” with a drop shadow).

•	 If the Shadow menu is not 
visible, click on its title bar to 
open it. Enter values of 75% for 
Opacity and 4% for Offset.
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Freeway Pro

•	Select the text, go to the 
Appearance tab of the 
Inspector and select the 
Shadow button (note that the 
“Normal Text Layer” button 
will also be selected).

•	 If the Shadow panel is not 
visible, click on its title bar to 
open it. Enter the values of 
75% for Opacity and 4% for 
Offset.

Because of the way Freeway works, if you want to 
change the text or any of the effects you’ve applied—
even after the file has been published—this text 
remains fully editable, so you can make your edits and 
simply republish.

Importing a graphic
Maurice uses a logo as part of his corporate identity, so 
we’ll put this logo on the right hand side of the page, 
over the top of the background header bar. This time 
we’ll import a graphic with transparency into a graphic 
item, scale the graphic and then position it on the 
page. This time we’re going to “drag and drop” the file 
straight from the Finder onto our Freeway page.

•	Locate the “Tutorial1_media” folder in the Finder and 
open it. Select the file “mauricecowley_logo.gif”, drag 
it from the folder and drop it onto a blank area of your 
page. The photo will appear on your page, already 
within a graphic item sized to the imported image.

•	Control-click (or right-click with a two-button mouse) 
on the item and select Graphic>Scale and Pad from 
the contextual menu. Control-click (right-click) again 
and select Fit Box to Content.

Using the Graphic>Scale and Pad command, the 
graphic will be scaled to the largest size possible within 
the item, while maintaining its proportions.

Using the Fit Box to Content command makes the 
item fit the physical proportions of the resized graphic.

Now we need to scale the graphic and the item to the 
size we want to use it on the page. We’ll use a modifier  
key combination to resize the item and image as one.

•	Select the General tab of the Inspector to view the 
item’s width and height. Hold down the Shift and 
Option keys, click on a corner of the graphic item and 
drag the corner handle to enlarge or reduce the  
Width and Height to 95px by watching the values 
change in the Inspector. Using Shift-Option-click and 
drag maintains the proportions of the image as the 
item is scaled. 

•	Go to the Appearance tab of the 
Inspector and apply an Outer Shadow 
with values of 75% Opacity and 4px 
Offset. In Express the Outer Shadow settings are at 
the top of the Appearance dialog. In Pro the Outer 
Shadow settings are in the Outer Shadow panel of 
the Effects panel.

•	Change to the General tab of the Inspector, then click 
and drag the item close to the top right-hand corner of 

Keeping your Freeway file size small
A tip to keep the overall Freeway document size small is 
to resample imported images. 

To resample an image, double-click it to open the 
Graphic dialog, then click the Resample button once. 
Click the OK button to close the Graphic dialog.

Resampling ensures Freeway stores the minimum 
information it requires for the imported image after it 
has been scaled.

! Tip
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the header bar and watch the X and Y values change 
(remember these are called Left Inset and Top Inset 
in Pro) in the Inspector. The item needs to have values 
of 590px for X and 16px for Y. You can click and drag 
it into position by watching the values change, or you 
can place it approximately and use your arrow keys to 
nudge it to the correct position one pixel at a time.

Adding HTML text
To complete the header bar, let’s add some words to let 
the world know his trade. We could use graphic text 
again, but we are going to use HTML text (see the “tip” 
box for the benefits of using HTML text).

•	Click once on the HTML button on the tool 
bar and draw an HTML item on a blank 
area of the page. Click on it again so the 
text cursor flashes inside the item and type the word 
“photographer”.

•	Select the word by double-clicking on it, then choose 
Helvetica for the font and 18px for the size in the 
Inspector. If necessary, make the item larger by 
dragging one of its handles.

With the text formatted we now need to click away 
from the item to deselect it and then reselect it with a 
single click so we can apply values to the item rather 
than the text. An alternative way to do this is to 
Command-click on the item.

•	Give the item values of 10px for X, and 125px for Y, 
then make the item 300px wide and 20px high.

Importing photos
Importing a photo into Freeway is no different to the 
way we imported the Maurice Cowley logo earlier. 
In fact all images are imported using the same basic 
methods. We imported the logo by dragging and 

dropping the graphic file straight on to the page: this 
time we will import a graphic by navigating to the file 
through the import dialog.

•	Draw a graphic item on the page as you did before, 
choose File>Import, navigate to the “Tutorial1_
media” folder, select the file called “beach huts.jpg“ 
and click Open. 

•	With the item selected on the page, make the item 
208px wide by 139px high by entering those values in 
the Inspector.

•	Control-click (or right-click with a two-button mouse) 
on the item 
and select 
Graphic> 
Scale and 
Trim from 
the contextual 
menu. 
Control-click 
(right-click) 
again and 
select Fit Box 
to Content.

Benefits of using HTML text on your site
It can be tempting to use graphic text in many places 
so you can choose a specific font or apply effects to the 
type.

However, HTML text is much faster to load in a 
browser and, unlike graphic text, it is accessibility-
friendly in that screen readers and Braille displays can 
read the text. This enables visually-impaired users to use 
the web site.

Another advantage of using as much HTML text as 
possible is that search engines will index the words of 
your page so search rankings should be more favorable.

! Tip



43

Tutorial

•	 If the Effects panel isn’t open, click on its header bar, 
then click on the Outer 
Shadow button. Enter 
values of 50% for Opacity 
and 8px for Offset.

Duplicating items
We are now going to make a duplicate of the photo 
we’ve just imported and styled on our page. A benefit 
of duplicating (or copying and pasting) an item is 
that all its properties will be retained. Freeway also 
remembers the scaling value along with the photo’s 
position within the item and these settings will also 

Scale and Trim works in a similar way to Scale and 
Pad, except that it scales the imported graphic 
proportionally so that its shortest aspect ratio fills the 
item, and the longest aspect is cropped equally on both 
sides or top and bottom.

When you draw a new item on your page and import 
a graphic, it will be imported at the same physical size 
it was saved at in the original graphics application. 
This can often mean that photos taken with digital 
cameras can be very large and so create big, unwieldy 
items when placed on your page with the drag-and-
drop method. If this is the case, you may find it easier 
to use the File>Import method used above.

We are now going to add a border and shadow effect 
to the photo – but as the methods of doing this are 
very different in Express and Pro, each version will be 
covered separately.

Freeway Express

•	Select the item, click the Appearance tab of the 
Inspector then click on the Border with shadow 
button. 

•	 If the Border or Shadow panels aren’t open, click on 
their header bars. In Border, choose white as the color 
and give it a size of 9px (check that 
Dash is set to a solid line and Position 
is set to “Outside”). In Outer Shadow, 
choose 50% Opacity and an Offset value of 8px.

Freeway Pro

•	Select the item and click on the Appearance tab of 
the Inspector. 

•	 If the Border panel isn’t open, click on its header bar. 
Choose white as the color and give it a size of 9px, 
making sure that Dash is set to a solid line and the 
Position is set to Outside.

Freeway Express

Freeway Pro
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apply to any graphic imported into this item at a later 
stage.

Another advantage of duplicating is that you can 
specify exact values to duplicate multiple items with 
specified horizontal and vertical offsets in a single 
operation.

•	Make sure there’s not an active cursor in any of the 
Inspector value fields and that the beach huts photo 
is selected. Choose Item>Duplicate to open the 
Duplicate dialog, 
set the Number of 
Copies as 2, leave 
the Horizontal 
offset as 0px, enter 
170px for the 
Vertical offset then 
click OK.

•	After duplication, both new items will be selected. 
Click on the page to deselect them both. Select the 
first duplicate, choose File>Import, navigate to the 
“Tutorial1_media” folder, select “sailing barge.jpg” and 
click Open. 

Let’s enlarge the image a little within the item. 

•	Control-click (or right-click) to reveal the contextual 
menu and choose Graphic>Scale Up. This enlarges 
the photo in small steps each time it’s applied. Do this 

two or three times. If you go too far, use Scale Down 
to go back one step.

We now need to position the 
photo within the item to make 
it visually interesting. To do this, 
we’ll use the “panning arrows” 
which are visible in the centre of 
the photo when it’s selected.

•	Move the mouse over 
the panning arrows so it 
changes to a hand icon, 
then click and drag the 
image freely within the 
item to place the image 
where you want.

When you’ve positioned the image within the item, 
click elsewhere on the page, to make the mouse revert 
back to a pointer.

Now let’s import the photo for the second duplicate.

•	Select the second duplicate item.
•	Choose File>Import, navigate to the “Tutorial1_
media” folder, select “low tide runnels in the sunlight.
jpg” and click Open. 

•	Control-click (or right-click) on the item and this time 
choose Graphic>Scale and Trim.

With all three photos imported and scaled, we’ll 
place them on the left of the page to make them look 
as though they are photographs scattered randomly 
on the page, as seen in the screenshot at the top of the 
next page.

•	Drag the photo items one at a time to the left 
side of the page below the item containing the 
“photographer” text. 

A shortcut for duplicating items
A quick way to duplicate an item is to click and hold 
on an item, hold down Option, then drag. This copies 
the item so you can position the duplicate where you 
want it to appear on your page.

Please note that this will not work if you click on the 
“panning arrows” in the centre of a graphic item.

! Tip
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tool in the tool bar, then click and drag one 
of the item’s selection handles. As the photo 
rotates, along with its 
border and shadow, you’ll 
also see two black lines 
which give an indication 
of the amount of rotation 
being applied.

•	Rotate the other two 
photo items in a random 
manner and place them so they overlap each other.

If you overlap the “photographer” HTML item with a 
graphic item when you reposition or rotate it, you’ll 
notice that the words in the HTML item will disappear. 

If this happens, move the graphic item away so it no 
longer overlaps the HTML item. This will return the 
HTML item to its previous state. When you’ve finished 
rotating the photos, click on the Select tool.

If you select one of the photo items and look at the 
General tab of the Inspector you’ll see that the photo 
items have the Combine Graphics 
option checked by default. This 
means that Freeway will treat all 
three items as a single graphic when it generates the 
HTML code.

Importing text
With the header and graphics placed, we now need to 
add some text. We’ll do this as HTML text.

•	Click on the HTML tool in the tool bar and draw a new 
item in a blank area to the right of the photos.

•	Click on the item again so it shows the text cursor, 
choose File>Import Text..., navigate to the text file 
called “welcome.txt” in the “Tutorial1_media” folder 
and click Open.

•	Select all the imported text, choose Georgia as the font 
in the Inspector and give it a size of 14px. Select the 
heading line “Welcome to my web site”, click on the 

Drawing item boxes on your page
When you draw a new item on your page, make sure 
you start to draw in a blank part of your page. 

If you draw on top of another item, the new item will 
become a “child” item of the original “parent” item. 
For the tutorials we don’t want this to happen, but 
“nesting” items inside other items can be useful, and 
you can read more about this in the Freeway 5 Reference.

Also, although it’s possible to physically overlap 
HTML items with other items on your page, it’s best 
avoided as they may not publish or preview correctly.

! Tip
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Bold button in the Style panel of the Inspector and 
select 18px for its size.

With the text imported, the item needs to be 
positioned on the page. To do this, you’ll need to 
Command-click on the item to select it so you can 
change the settings of the item rather than the text 
inside it.

•	 In the General tab of the Inspector, set the X value as 
348px, the Y value as 200px, then the W and H values 
as 350px and 180px respectively.

To finish off our page, let’s put a box panel on the page 
to announce Maurice’s new exhibition. Again this will 
be done as HTML text. 

•	Select the HTML tool in the tool bar and draw a new 
item below the Welcome text item. 

•	Click on the item to get a text cursor, choose 
File>Import Text..., navigate to the  
“Tutorial1_media” folder, select the file called 
“exhibition.txt” and click Open.

•	Select all the text in the item, go to the Inspector and 
set Align to Center in the Paragraph panel. Choose 
Helvetica as the font in the Character panel and 12px 
for the size.

•	Feel free to select individual lines and give emphasis to 
important lines by increasing the size and using bold or 
italic in the Style panel.

•	Command-click on the item, go to the Appearance 
tab of the Inspector, and choose white as the color.

•	Go to the General tab of the Inspector and enter 
a value of 10px in the Padding field to add space 
between the text and the item’s edge.

Tips on importing text into Freeway
Some word processing programs use invisible coding 
to format and style its text. When text is imported 
(or copied and pasted into Freeway), this code can be 
brought in as well. We recommend that text (.txt) files 
are used, rather than “rich” or formatted text files (such 
as .rtf or .doc).

It’s also good practice to remove any extra carriage 
returns at the end of your text by placing the cursor at 
the end of the text and using the Delete/Backspace key 
to delete anything after the last character.

! Tip

•	Set values of X 348px, Y 395px and W 328px for the 
item in the Dimensions panel in the General tab of 
the Inspector. 

•	To finish, we can choose Item>Fit Box to Content 
to make the item fit the content exactly. As this is an 
HTML item, this will only affect the height of the item.
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•	Choose File>Save to save the changes.

You’ve just created a web page in Freeway.
So far, we’ve only seen what the page looks like 

within Freeway, and no HTML code has been 
generated.

Previewing your page
It’s a good idea to check how things are going to 
look in a browser as you work. Freeway has a built-in 
function called Preview which uses the same graphics 
engine as Apple’s Safari browser.

Just below the tool bar, three buttons allow you 
to switch between the Master, Page (currently 
highlighted) and Preview views. 

•	Click the Preview 
button. Freeway 
switches to Preview 
mode, and a progress 
bar will show that it is building the page. After a 
few seconds, the page will appear in the document 
window.

Notice that the tool bar icons have changed. There 
are buttons here that let you test your site to see how 
it might appear if images or JavaScript have been 
disabled in a visitor’s browser, and it lets you test the 
site to see if the layout is OK when the size of HTML 
text is increased or decreased. Note: Freeway Pro users 
have additional functionality, such as an “accessibility 
report” to see if a page conforms to international 
accessibility guidelines (so it can be used by visitors 
with disabilities).

Using Preview, you will only be able to view the 
active page in your Freeway interface window.

This is an easy way to test a page, but while it 
replicates many features of a browser, it’s really just a 
way to get a quick look at a single page as you work. 
To check how an entire web site works, you’ll need to 
preview it in a proper browser and we’ll look at that in 
the next tutorial.

•	Click the Page button to return to your Freeway page.

Although you were probably unaware of it, Freeway 
converted your page into HTML code when you clicked 
on Preview. Every time you select Preview, Freeway 
generates all the code, optimized graphics, etc., then 
places everything you need for that page into your 
Site Folder. This is also known as “publishing” the 
page. What you’re looking at when you preview is the 
information written to your disk as HTML code and 
interpreted by a browser.

When you preview the page in a browser, the HTML 
code for the entire site is generated, rather than just a 
single page when you use Freeway’s internal Preview. 
Another way to make Freeway generate the HTML code 
for the entire site is to choose File>Publish Site.

Once a site has been published, further publishes 
will only generate the HTML code for those pages 
which have changed since the last time the site was 
published.

This is the end of the first tutorial. For the next 
tutorial, we’ll re-use parts of this Freeway file again 
to create a multi-page site with hyperlinks in a new 
document.
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In the first tutorial we created a single page in Freeway. 
By the end of this tutorial, we’ll have a multi-page site 
with links established so users can navigate through 
the entire site by clicking on hyperlinks.

If we were working on a “live” project (rather than 
a tutorial) we would probably have started our site by 
creating all the common items on a Master page. For 
this reason, we’ll discuss the concept of Master pages 
before we resume the next stage of Maurice’s site.

Basic concepts of Master pages
Freeway is similar in many ways to a Desktop 
Publishing (DTP) program—and just as DTP programs 
offer the facility to use multiple Master pages, so does 
Freeway.

When used well, Master pages aren’t just a good way 
to speed up the workflow of web design, they also help 
to give a better consistency across your site.

Everything placed on a Master page, together with 
any formatting and functionality applied to its items 
will appear on every page created from that Master.

When changes are made to a Master page, all the 
pages created from that Master will have the same 
changes applied. However, it’s important to remember 
when working with Master pages that if an item is 
moved or edited on a page created from that Master, 
those items will lose their connection to the equivalent 
item on the Master page.

If this happens, subsequent changes made on the 
Master page will not be applied to those items. For this 
reason, it’s good practice to “lock” items on Master 

pages to prevent them being moved (this will be 
covered later in the tutorial).

If you have moved or edited an item that is based 
on an item on a Master page, you can re-establish 
the connection by turning on the Use Master 
Content and Use Master Settings checkboxes in the 
Properties panel of the General tab of the Inspector for 
that item.

It’s not just common items that make Master pages 
so indispensable. Many things—such as page size, 
background color and even any Actions or child items 
used the page—can be restored or ignored when a new 
page is created from the Master.

There may also be times when you want to use more 
than one Master page—for instance, different sections 
of your site may have a different color scheme—in 
which case, you can simply create a new Master to 
work from. Freeway also allows you to duplicate an 
existing Master by clicking on an existing Master page, 
and choosing Page>Duplicate Page....

Tutorial 2

Setting a universal page size for your site
You can change the page size of a Master page in 
the General tab of the Inspector—however, any new 
Masters you create will need to have their sizes changed 
as well. 

To change the default page size for all 
pages (including Masters) of your site, choose 
File>Document Setup... and change the default size 
there. This will affect all pages that haven’t had their 
sizes changed manually, and all pages created from 
then on.

! Tip
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The Site panel
When working on multi-page sites, the Site panel—
which is to the left of the layout or document area—
becomes an invaluable aid to navigating around the 
site to edit and manage your pages.

The Site panel has two distinct parts—Master pages at 
the top and normal site pages below.

To change the names of Master pages, pages and 
items in the Site panel you need to Option-click on 
either the icon or its current name.

Setting up a Master page
We started the first tutorial with a blank template and 
created the whole page on a normal site page. Freeway 
lets you work the way that suits you—and, whereas 
some people like to plan their site before they start, 
others prefer to design on the fly. 

Now we’ve created our first page, we know which 
items we want to use on every page, so we can place 
those items on a Master page. 

Of course, those who planned ahead may have 
chosen to place the items common to all pages on a 
Master page as a starting point when they began work 
on the site. For this tutorial we’ll create a new site and 
make a Master page in it with the same settings as the 
page in the first tutorial, then copy the common items 
across to the Master page and the page-specific items to 
a site page.

•	Open the Freeway file for the first tutorial if it’s not 
already open.

•	Choose File>New... to create a new document using 
the Blank template and give it the title of “Tutorial2”.

•	 In the new document, click on the Master page 
“Master1” in the Site panel, set the page dimensions to 
700px by 700px, choose “Center” in the Align popup 
and choose “Fixed” in the Width popup.

•	Set the same page background color as the first 
tutorial—CCFFCC (as a web-safe color), or 204, 255 
and 244 (as an RGB color).

•	 Import the “header_bar.gif” graphic as a background 
image for the page, set Horizontal to “Center”, 
Vertical to “Top” and Tile to “Neither”.

The Site panel doubles up as the Page panel—you can 
toggle between these two states by selecting a page in 
your page list, then clicking on the “Site” bar at the top 
of the panel. In Page panel mode you will see a list of 
all the items used on that page.

The list of items viewed in Page panel mode can 
often be the simplest way to find an item to edit—for 
instance when you have a stack of items on top of 
each other—in which case you can select the item by 
clicking once on its name in the page mode of the Site 
panel.
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You can also change the names of Master pages in the 
Site panel and items in the Page panel by this method.

Working on a Master page
You’ll notice that when you are viewing a Master page, 
the page rulers are displayed in a pastel yellow color. 
This is a visual cue that you’re working on a Master 
page.

To navigate between a normal site page and the 
Master it was created from, you need only to click on 
the Master and Page buttons located at the top left of 
the layout/document area. When viewing a Master page, 
clicking on the Page button will take you to the page 
created from that Master which was last worked on.

Earlier in this tutorial we discussed how the 
connection to an item on a Master page is broken if 
the item is moved on the site page. To prevent this 
happening, it is good practice to lock an item on a 
Master page.

•	Click once on “Master1” in the Site panel.
•	Select one of the items and choose Item>Lock, or 

Control-click on the item and choose Lock from the 
contextual menu. 

•	Repeat this for all the items in turn.

A locked item’s selection handles display in red.

•	Choose Window>Tutorial1 to switch to the 
document created in the first tutorial, click once to 
select the logo text, then Shift-click (which will add 
to the selection) on the graphic logo item and the 
“photographer” item.

•	With all three items selected, choose Edit>Cut to cut 
the items from the page.

•	Choose Window>Tutorial2, select the “Master1” 
page in the Site panel and choose Edit>Paste.

Freeway will remember the position of items cut from 
the original and will place them in exactly the same 
position on the Master page, so no repositioning is 
necessary.

The above procedure has placed the common items 
on the Master page of our new site. Now we need to 
copy the page-specific items to our new site page.

•	Choose Window>Tutorial1 again to go back to the 
original page made in the first tutorial.

•	Choose Edit>Select All to select all the remaining 
items on the page, then Edit>Cut. Close the file by 
choosing File>Close without saving the changes.

•	 In the new Tutorial2 document, click on the “Untitled” 
site page in the site panel and choose Edit>Paste.

Naming pages and files in the  
Site panel
Freeway, by default, names pages “Untitled1”, 
“Untitled2” and so on. Let’s rename the site page so it 
can be easily identified in the Site panel.

•	Option-click on the “Untitled” page in the Site panel 
list. This will highlight the name and make it editable.

•	Type “Welcome” as the title, then type a Return.
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Freeway lets you create multiple Master pages to 

ensure consistency across your site—for instance when 
you want sections of your site which are visually very 
different or when you need a multiple-language site.

Adding pages to a site
Now that we have created a Master page containing 
the items common to all the pages of our site, we can 
add some more content pages. We’ll add two pages—a 
gallery page, containing examples of Maurice’s work, 
and a contact page so visitors can get in touch with 
him.

•	Choose Page>New Pages from the menu bar.
•	The New Pages dialog box will appear. Give the page 
the title of “Gallery”, leave the Pages field as the default 
of “1”, and click OK.

on all three pages in turn to see that the items on the 
Master page display on all three site pages.

Title and file names for pages
Freeway uses two distinct parts to naming pages—
which you can see in the General tab of the Inspector. 
First, is the Title, which is the name that appears in 
your Site panel list and in 
the upper title bar of the 
browser window when the 
page is viewed in a browser. 
Second, is the File, which is 
the file name of the .html file 
given to the page when it’s 
published by Freeway. 

Freeway automatically 
handles the second, basing 
the File name on the Title 
you enter—though you can 
override this if you want.

There is one exception to 
the rules on naming pages, 
and that is the File name of the first page of your site. 
This page usually needs a file name of index.html, 
so visitors to your web site only have to enter the web 
address in their browsers, without needing to add a 

A shortcut for adding new pages
You can also add new pages, one at a time, to your site 
by clicking and dragging a Master page into the site 
pages area of the Site panel.

•	Create another new page, give it the title of “Contact 
page” and click OK.

The Site panel area below the Site Folder now contains 
three pages—our original “Welcome” page, along with 
the new “Gallery” and “Contact” pages. You can click 

! Tip
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specific file name as well. 
Freeway automatically enters 
index.html as the File name 
for the first page in the Site 
folder for you.

Select the first site page in 
the Site panel, which is our 
Welcome page, and check 
that “index.html” appears in 
the File field in the General 
tab of the Inspector.

Adding content to 
the new pages
For our Contact page, 
we want a text block in exactly the same place as 
the Welcome page. This is very simple as Freeway 
remembers the position of copied items, so they will 
appear in the same position when they’re pasted.

•	Select the Welcome page in the Site panel, select the 
HTML item containing the “Welcome to my web site” 
text and choose Edit>Copy.

•	Click on the Contact page in the Site panel and choose 
Edit>Paste.

•	Click on the newly pasted item to get a text cursor, 
choose Edit>Select All and use the Backspace/Delete 
key to delete all the text in the item.

•	With the text cursor still inside the item, choose  
File> Import Text..., navigate to the  
“Tutorial2and3_media” folder, select the file called 
“contact.txt” and click Open.

•	Select all the imported text, then check the font is still 
set to Georgia and the size to 14px in the General tab 
of the Inspector. Select the top line of the text then, in 
the Inspector, click on the Bold button and make the 
size 18px.

Let’s add some visual interest to the page.

•	Draw a small graphic item to the left of the HTML text 
item. Go to the General tab of the Inspector and give 
it an X value of 10px, a Y value of 165px, a W value 
of 288px and an H value of 490px. Now we need to 
import a photo into the item, but to do this we’ll need 
to either type a Return to accept the last value or click 
once on the item so the Inspector lets us access the 
drop-down menus in the menu bar—see “Tip” box 
below.

•	With the graphic item selected, choose File>Import, 
navigate to the “Tutorial2and3_media” folder, select 

Naming your web site’s “Home” page
Although the name “index.html” is by far the most 
common name for the base level page of your site, it 
can depend on your web hosting service.

The documentation you received from your web 
host may specify a particular name for the “home” 
page. If it doesn’t, use “index.html”

However, if you find that “index.html” doesn’t work 
after you’ve uploaded your site, you should contact 
your web host to ask them what name you should use.

Exiting the Inspector to access menus
You may notice that occasionally all of the menu items 
in the menu bar are disabled after you’ve been making 
changes in the Inspector. This is almost always because 
the text cursor is still active in a field in the Inspector.

To return the menus to normal, either type a Return 
or click in the main Freeway window.

! Tip

! Tip
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on the photo and choose Graphic>Scale and Trim.

Now let’s add some content to the Gallery page. Note 
that we’re only adding the items at this stage—in the 
next tutorial we’ll add the items’ functionality.

•	Click on the Gallery page in the Site panel, select the 
Graphic tool and draw a graphic item on the page. 

•	Type “GALLERY” inside the item. Select all the text, go 
to the General tab of the Inspector to change the font 
to Helvetica Regular and make the size 24px. Click on 
the Center Align button to center the text.

•	With the text still selected, enter 40% as a value in 
the Space field and type a Return or Tab. If the text 
disappears, make the item larger until it reappears.

•	Command-click the item to select it then give it values 
of X 0px, Y 195px, W 700px and H 32px in the 
Inspector.

The value of 40% entered in the Space field (which is 
only available for graphic text) letterspaces the word.

The gallery page will eventually offer a feature where 
the visitor can select a thumbnail to view a larger 
version of the same photo, so let’s create the layout 
ready for this functionality to be applied in the next 
tutorial.

•	Draw a small graphic item on the page and make it 
60px square. Apply a border in the Appearance tab of 
the Inspector—select white for the color, give it a size of 
5px and change the border position to Inside. 

•	Position the item using values of X 10px and Y 247px.

We’re going to use this item to create a row of 
thumbnails across the page, which is a very simple task 
in Freeway. 

•	To gain access to the drop-down menus, remember 
to type a Return after the last value entered into 
the Inspector or click once on the item. Choose 
Item>Duplicate... or Control-click on the box and 
choose Duplicate... from the contextual menu. Enter 8 
for the number of copies, then 77px for the horizontal 
offset (set the vertical offset as 0px) and click OK. 

Drawing squares and circles in Freeway
You can draw a perfect square with the HTML or 
Graphic tool, or a perfect circle with the Oval tool, 
by holding down the Shift key as you draw. This will 
constrain the item you draw to an equal height and 
width.

! Tip
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On the page we should now have a row of identical 
items—so let’s import a different image for each item.

•	Select each item in the row in turn, then import the 
photo corresponding to the list below (from left to 
right). Control-click and choose Graphic>Scale and 
Trim from the contextual menu for each photo:

	 1.	“beach huts.jpg”
	 2. 	“weathered sea wall.jpg”
	 3.	“birds at low tide.jpg”
	 4.	“footprints in wet sand.jpg”
	 5.	“groynes in winter.jpg“
	 6.	“low tide runnels in the sunlight.jpg”
	 7.	“marsh.jpg”
	 8.	“misty riverside.jpg”
	 9.	“wheeling gulls.jpg”

To complete the Gallery page for this tutorial, we 
need to create an item in which we’ll eventually 
display a large version of each photo we used for the 
thumbnails. For now, we’ll create and position just a 
single item.

•	Click on the Graphic tool, draw an item below the 
thumbnails then position and size the item using the 
values X 145px, Y 345px, W 399px, H 266px.

•	We need to access the drop-down menus again, so type 
a Return after the last value entered or click once on the 
item. Choose File>Import..., select “beach huts.jpg” 

from the “Tutorial2and3_media” folder and click Open. 
Control-click on the item and choose Graphic>Scale 
and Trim.

•	 In the Appearance tab of the Inspector apply a 
Border with shadow as we did for the photos on 
the Welcome page. We need a 9px white border set to 
Outside and a shadow with 50% opacity and an offset 
of 8px.

Applying hyperlinks
The World Wide Web works like a “web” because pages 
have hyperlinks between them, allowing visitors to 
click to navigate within a web site, or to other sites on 
the web.

Resampling all the images in your site
In the first tutorial we gave you a tip for resampling 
individual graphics to help keep the size of your 
Freeway file to a minimum. If you want to resample all 
the images in your site in a single operation, you can 
choose Edit>Resources and click on the Resample All 
button.

! Tip
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Hyperlinks are one of the key features of the web. 

When used well, they guide the user along a logical 
and intuitive route through your web site, as well as 
linking to resources on other sites. Hyperlinks can also 
be used to launch an email program to display a new 
mail window containing an email address you specify 
and also, optionally, a subject.

For this tutorial we’ll cover basic text hyperlinks. 
Other ways to create hyperlinks will be covered in the 
next tutorial, when we create a dynamic navigation 
bar.

Let’s apply some hyperlinks to some of the words in 
the text of Maurice’s Welcome page. 

•	Click once on the Welcome page in the Site panel.
•	Click inside the Welcome text item and double-click on 
the word “Gallery” in the second paragraph. With the 
word highlighted, choose Edit>Hyperlink....

•	At the top of the Edit Hyperlink dialog box, the 
Internal tab should be selected. If not, click on it. 
Select “Gallery” in the internal page list, then click OK.

You’ll notice that the word “Gallery” is now underlined 
and has changed to blue. This is the default style of 
hyperlinks in most web browsers.

Let’s also create a hyperlink to the Contact page.

•	Double-click on “Contacts” in the third paragraph. 
With the word selected, Control-click on it to reveal the 
contextual menu and choose Hyperlink....

•	 In the Edit Hyperlink dialog, click on “Contact page” in 
the internal page list and click OK.

Now we can create hyperlinks on the Contact page. 
These, however, are different types of hyperlinks to 
those created on the Welcome page. The first is an 
email link, the other is a link to an external web site.

•	Click on the Contact page in the Site panel.

Internal hyperlinks and Freeway
Because Freeway manages all your site pages and files 
for you, it will automatically update your links if, later 
on, you decide to change the names of your internal 
pages.

Please note, however, that this doesn’t apply to any 
external links you use.

! Tip
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Adding a subject line to an email address
You can automatically add words to the “Subject” field 
in a visitor’s email program when they click on an 
email link. 

To do this, type “?subject=yoursubject” (without 
the quotes) immediately after the email address you’ve 
entered in the dialog window. Substitute “yoursubject” 
for whatever you want the subject field to be in the 
email.

•	Select “Email me here” in the text item and make it a 
hyperlink using either of the methods described earlier. 
In the Hyperlink dialog box, click on the External tab 
and choose mailto: from the Protocol pop-up menu. 

•	Freeway will add “mailto:” in the main text field of the 
dialog box, so all you need to do is add Maurice’s email 
address after “mailto:”, without typing a space. Type 
“mauricecowley@softpress.com”, then click OK.

Now let’s create an external link to another web site. 

•	Select the word “Softpress” in the last paragraph and 
choose Edit>Hyperlink. 

•	 In the dialog box, click on External and, this time, 
choose http: from the Protocol menu. 

•	Freeway automatically adds “http://” in the main text 
field of the dialog box, so click after the text and type 
“www.softpress.com”.

•	Because we want this page to open in a new browser 
window, click on the Target menu and choose  
“New Window/Tab _blank” and click OK.

We now have some text links established, but you 
may have noticed that so far we don’t have a way to 
navigate from one page to another and back again. In 
the next tutorial we’ll create a navigation bar using a 
Freeway Action which makes the process of making a 
dynamic navigation bar really quick and simple, but 

! Tip
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for now we’ll build a text navigation bar so we can test 
the links in our site when it is previewed in a browser.

As this will be a common item to all pages, we’ll 
create this on our Master page and we’ll set up the 
hyperlinks using a new method. 

•	Click on the “Master1” Master page in the Site panel 
and draw an HTML item in a blank part of the page. 
Click on it again so we can add text. 

•	Type “Welcome | Gallery | Contact page” (you can 
access the “|” character by typing Shift-\). Select all the 
text, make it 14px Georgia using the General tab of 
the Inspector and click on the Center Align button in 
the Paragraph panel.

•	Select the word “Welcome”, then click on the 
“Hyperlink box” popup which is found at the bottom 
left of the page area. This will display a list of all 
the internal pages within your site – so choose the 
Welcome page at the top of the list to apply the 
hyperlink. Do the same for the “Gallery” and “Contact 
page” text to link them to their relevant pages.

•	Command-click on the item to select it then position 
and size it using the following values: X 349px,  
Y 677px, W 350px and H 22px. 

If you choose any page in the Site panel, you can see 
that we now have this text navigation menu on every 
page and the links are underlined and shown in blue.

•	Save your file by choosing File>Save.

Previewing the site in a browser
The last time the site was tested, we previewed a single 
page by using the Preview button below the tool 
bar. However, to test hyperlinks the site will need to 
previewed using one of the real browsers you have on 
your computer.
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•	Choose File>Preview in Browser and select one of 
the browsers in the list.

The first time Freeway is launched after installation, 
it scans your computer’s hard disk for browser 
applications and you will see them listed in the menu 
viewed by choosing File>Preview in Browser.

If you later install a new browser which isn’t then 
listed, go to the Preview in Browser menu and select 
Browser Setup... where you can click on New... to 
add the browser to the list. 

You can also delete browsers you don’t want to use 
and choose a default browser which can be accessed 
using a keyboard shortcut.

Previewing in a browser will publish pages in your 
site to generate their HTML code and, unlike Preview, 
it will publish all the pages of your site. If there have 
been a lot of changes since the last time you published 
the file, this may take a few seconds to complete.

Once the browser displays your site, you can test the 
hyperlinks by clicking on them to navigate around the 
different pages. 

You can test the email link by clicking it on the 
Contact page, which will launch the default email 
application used by your computer. Once loaded, you 
will see a new email message with Maurice’s email 
address already entered as the recipient. 

Next, test the external link by clicking on the 
Softpress hyperlink on the same page. Because the 
“target” was set to “_blank” in the hyperlink dialog 
box, this will open in a new browser window or a new 
browser tab depending on how you browser is set up.

You may have noticed that before we previewed the  
site in a browser, all the pages in the Site panel showed 
a black dot to the left of the page name. This indicates 
that the pages are “dirty”—which means that changes 
have been made since the site was last published. Only 
pages which have had changes made to them will have 
the dot displayed next to them—however, if a Master 
page is edited, all the pages created from that Master 
will be marked as dirty and in need of publishing.

This completes the second tutorial. For the next 
tutorial, we’ll use this Freeway file again, and add 
dynamic effects to the site using Freeway Actions.
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One of the great things about web sites is that, unlike 
a book, the pages can be dynamic and interactive. In 
this tutorial we’ll add functionality and dynamic visual 
effects to enhance Maurice’s site.

Creating these effects can be quite time-consuming—
but with Freeway, they can be quickly and simply 
added to your site by using Freeway Actions.

Actions are to Freeway what plug-ins are to other 
programs. A core set of Actions ships with Freeway as 
standard, but many more are available to download 
for free from ActionsForge (http://actionsforge.com/). 
Some, usually very complex or specialized Actions, are 
available to buy from the authors who wrote them.

Although Freeway Actions are written using 
JavaScript, they usually require no coding knowledge 
and are applied using user-friendly interfaces displayed 
in the Actions palette.

In this tutorial we’ll use two different types of 
Actions—Item Actions and Standalone Actions. There 
are also Page and Folder Actions, which you can read 
more about in the Freeway Actions guide.

Graphic hyperlinks
In the last tutorial, we created some text hyperlinks. 
However, graphic hyperlinks—which are simply 
hyperlinks applied to graphic items—can’t be visually 
identified in the same way as the blue underlined text 
links. For hyperlinked graphic items, Freeway displays 
a blue globe in the top left corner of the item to give a 
visual cue that a link has been established on the item.

Graphic hyperlinks are created in the same way as 
text hyperlinks, let’s set up a link on the namestyle. 

•	Click on the “Master1” Master page in the Site panel 
and select the graphic containing the “mauricecowley” 
text. The item is locked, so it can’t be moved, but it can 
still be selected. 

•	With the item selected, click on the hyperlink box 
popup below the bottom left of the page area, which 
currently displays the words 
“No Link”. 

•	This reveals a menu of all 
the internal pages of our 
site along with a submenu 
for external links. Choose 
the Welcome page.

Now that we’ve made the item a hyperlink, you’ll 
see that a blue 
globe symbol 
has appeared in 
the top left-hand 
corner of the item. 
This tells us that the graphic has a hyperlink applied.

Creating a navigation menu using the 
CSS Menus Action
One of the essential features of modern websites is an 
attractive navigation menu to give visitors a visual cue 
that the links to the pages are active when they interact 
with the menu by moving their mouse over the link. 
This can be done by making it swap its color or some 
other change—and Freeway offers a built-in Action to 
make the creation and editing of such a menu really 
quick and simple to do.

Tutorial 3
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The CSS Menus Action is very full-featured and it can 
make drop-down-and-fly-out menus with submenus 
(and various levels of sub-submenus) so the visitor 
can move their mouse over the main menu to see sub-
menus below (on horizontal navigation menus) or to 
the side (on vertical menus). It is also possible to embed 
graphics inside the “cells” of the navigation menu so 
they can be made to appear or change on mouseover. 
Full details of all the features of the CSS Menus Action 
are available in the Freeway Actions Guide, but for this 
tutorial we will use just main menus which change 
color on mouseover and display a “Current Page” state.

For the CSS Menu Action to be applied, you need to 
have an HTML item selected which contains only “list” 
text. As with all things in Freeway, unless you have an 
item selected which can have the Action applied to it, 
you won’t see the Action in the list of Actions.

•	Click on the “Master1” Master page in the Site panel 
and draw an HTML item in a blank part of the page. 
Click on it again so we can add text. 

•	 Inside the item, enter “Welcome”, type a Return, enter 
“Gallery”, type another Return, then enter “Contact 
page”.

List text is just text which is formatted to show bullets 
or numbers at the start of each new line. You don’t 
need to change the List Style popup—just leave it in its 
default setting.

Now that the text is formatted as a list we can now 
apply links to the text in the item then apply the CSS 
Menus Action to the item itself.

•	Select the word “Welcome” and apply a hyperlink to 
the Welcome page. Repeat this for the other lines of 
text so they link to the Gallery and Contact page.

We now need to choose the text styling we want to use 
on the text. With CSS Menus it is very important that 
only the Font, Size and Align is used—this is because 
the Action controls all the color attributes.

•	Select all the text inside the item, click on the Center 
Align button then use Helvetica for the Font and 14pt 
for the Size.

Now the text has been entered and styled, we can now 
apply the Action to the item.

•	Command-click on the item (to select the item rather 
than the text inside it) and go to Item>Actions and 
choose CSS Menus.

With the Action applied, the item now displays in 
dark grey with a message stating: “PUBLISH to see 
something”. The reason this appears is because (as we 
have discussed earlier) there is no HTML in the Freeway 

•	Select all the text in the item by going to Edit>Select 
All.

•	The text now needs to be made into list text so, with 
the text still selected, click once on the Right Arrow in 
the List panel of the Inspector.
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workflow until the file has been published. Once the 
file is published, Freeway can then build a live preview 
by reading the code in the Site Folder—however, we 
also discussed earlier that Master pages do no publish, 
so it’s not possible for Freeway to show a preview of the 
menu. Because of this, it’s best to move the CSS Menu 
item to a normal site page, and then it can be pasted 
onto the Master page once we’re happy with how it 
looks and works.

Normally, one of the first things you will create on 
your page after the header bar and other common 
items is the navigation bars, but as the tutorial pages 
are quite full, we will create a new page so the CSS 
Menu item can be built on a site page, which will give 
us the benefit of seeing a preview as we work.

•	Select the CSS Menu item and go to Edit>Cut.
•	Go the Site Panel and drag the Master1 Master page 

to a position below the Contact Us page and let go of 
the mouse button. In the New Page dialog, give it the 
name of “testpage” and click OK.

•	Paste the CSS Menu item onto the “testpage” page by 
going to Edit>Paste.

•	With the item selected, position and size it using the 
following values: X 348px, Y 149px, W 350px and  
H 24px. 

•	Now preview the file in a browser.

Once the file is previewed in a browser, you will see 
that when you return to your Freeway file, the CSS 
Menu is now displaying a live preview. At the moment 

it looks quite strange—so let’s apply some settings to 
the menu in the Actions palette.

If the Actions palette is not open, go to 
Window>Actions to display it and then make sure the 
CSS Menu item is selected on the page.

•	Check the Highlight 
Current Page option (this 
means that the CSS Menu 
can display a specific link 
state for the Link text and 
Background color when 
you are on that page).

•	Click the disclosure triangle 
to the left of Size and 
Shape to open the Size 
and Shape panel.

•	Make sure the Layout 
popup is set to 
“Horizontal”.

•	Make sure the Alignment 
popup is set to “Left” (this 
aligns the CSS Menu within 
the item).

•	Switch on the Use 
Content Width option 
(this gives even spacing 
between each main menu text, regardless of how wide 
the text is, rather than using “cells” of the same width).

•	Change the Right and Left Padding values to 26px (to 
give more spacing between each main menu item).

•	Open the Links panel and choose the color of the text 
used for linked text for each state. I have used black for 
Link, Hover and Click, then white text for the current 
page state (rather than to add new colors). You can use 
whatever colors you want.
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•	Open the Background panel and then switch on the 
Background option. Choose the color you want to use 
in the background for each hyperlink state. I’ve used 
cyan for Color, green for Hover and Click, and blue for 
the Current Page state (rather than to add new colors). 
You can use whatever colors you want

•	Switch off the options for Border, Item Dividers and 
Arrow. These are additional features which we are not 
using here.

• Now preview in a browser to see how the color 
backgrounds change on mouseover.

Although the CSS Menu item used here is very simple 
and bright in color, it is possible to make very attractive 
and functional multi-level menus using the Action.

We now need to cut the CSS Menu from the 
“testpage” page and paste it onto the Master1 page, 
then we can remove the test page.

•	Select the CSS Menu item and go to Edit>Cut.
•	Select the Master1 Master page in the Site Panel and 

paste the item on there by going to Edit>Paste.
•	Control-click (or right-click) on the “testpage” page in 

the Site Panel list and choose Delete in the contextual 
menu to remove the page from the Freeway file.

•	Click on the Welcome page and then preview in a 
browser to see the CSS Menu working (you will now 
see the Current Page state working) and test the links 
by visiting the different pages of the site.

Creating a simple photo gallery
Maurice wants visitors to see large versions of his 
photos, but he wants them to appear on a single page 
rather than a page for each photo. Although this can 
be done with Freeway’s Showcase application and 
Action, for this tutorial we’ll do it by making each 
thumbnail on the Gallery page a “rollover” to trigger 
the display of a larger “target” photo below.

Although many people think of a rollover as being 
just a graphic which swaps an image on mouseover, 
a rollover can also be something which triggers an 
“event” on mouseover or click. For this tutorial we are 
going to set up the row of thumbnail images so they 
display a soft shadow on mouseover while it triggers 
the display of the large version of that image below.

•	Click once on the Gallery page in the Site panel.
•	Click and drag a selection marquee around all of the 

thumbnails, choose Item>Duplicate and enter 1 for 
Number of Copies and 0px for both offsets. Click OK.

•	Click on a blank area of the page to deselect all the 
items, then reselect the first thumbnail.

•	The thumbnails already have borders applied, so click 
on each thumbnail one at a time and click on the 
Border with Shadow button 
in the Appearance tab of the 
Inspector. Use the values of 50% 
Opacity and an Offset of 6px 
in the Outer Shadow panel.

•	Do this for each of the 
thumbnails in turn.

Freeway Pro users need to use the separate 
Border and Shadow panels (using the same values as 
above) as they did when setting up the scattered photos 
on the Home page.

Pro
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To make rollovers in Freeway we need to place two 
or three graphic items on top of each other and then 
choose which graphic we want to appear in each of the 
Normal, MouseOver and Click states. For rollovers to 
work, however, it is important to note that the graphic 
items need to “combine” with each other.

If you select one of the thumbnail images on your 
page and look in the General Settings tab of the 
Inspector, you will see that the 
“Combine Graphics” option is 
checked (which is the default 
behavior). When the Combine Graphics option is 
checked, all graphic items place on top of each other 
(or overlap) will be treated by Freeway as a single 
graphic—and this means that the graphic displayed for 
each state of the rollover (or stack of target images, see 
later) can be controlled in Freeway’s Actions palette.

Let’s set up the first thumbnail as a rollover.

•	Select the left hand thumbnail image (beach huts), go 
Item>Actions and choose Rollover.

•	Make sure the Actions palette is open, if it isn’t, go to 
Window>Actions to open it.

•	With the thumbnail selected, you will see the Actions 
palette displaying two item in the Normal column— 
“beachhuts” and “beachhuts2”. 

By default, Freeway will always list all combining items 
placed on top of each 
other on the page in 
the Normal column.

•	Click on the checkmark for “beachhuts2” in the Normal 
column (to remove it) and then click once in the same 
row under the MouseOver column so one checkmark 
appears in the first two columns.

You can test how things will work when viewed in a 
browser by clicking on the “Normal” and “MouseOver” 
header bars to see which graphic displays in each state.

•	Repeat this same procedure for each other thumbnail.

There are two parts to the Rollover Action palette 
(see screenshot below left)—the Images tab and the 
Parameters tab. As we have seen, the Images tab 
controls which graphic is shown in each of the rollover 

IMPORTANT NOTE
EXPRESS USERS: If you only see one item in the Actions palette list, 
select and delete each duplicate thumbnail item, select the original 

thumbnail items one at a time and switch ON the Combine Graphics 
option in the Inspector. After that, select all the thumbnails and duplicate 

them again before applying the Rollover Action.

PRO USERS: If you only see one item in the Actions palette list, switch 
OFF the CSS Layout button and build your rollovers again from the 

previous page

A tip to identify the elements of a rollover
If you find it difficult to identify your items in the 
rollover dialog, consider giving them logical names. 

This can be done by clicking on the “Site” header bar 
at the top of the Site panel to change it to “Page” view. 
You can then select an item and rename it, perhaps 
with a logical naming convention such as “beachhuts_
normal”, “beachhuts_mouseover”, etc. To change an 
item’s name in the list, you’ll need to Option-click on 
the name and enter the new name.

! Tip
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states (though note that we didn’t use the Click state 
for this tutorial). The Parameters tab is where we set the 
“triggers” for the Rollover, and we will revisit this later, 
once we have created a stack of target images we want 
each rollover to display on mouseover.

Let’s build the stack of large images. We already have 
the large version of the “beach huts” photo, which 
corresponds to the first thumbnail, so let’s duplicate 
that large item and then import a large version of the 
photo used in each of the other thumbnails. Because 
we need to import a different image into each new 
large item, we’ll need to do this one at a time.

•	Select the large image of the beach huts and choose 
Item>Duplicate, ensure the values are still set to 1 
copy and 0px for both offsets. Click OK.

•	Choose File>Import, navigate to the folder 
“Tutorial2and3_media” and select the image used for 
our second thumbnail (called “weathered sea wall.jpg”) 
and click Open. Control-click on the item and choose 
Graphic>Scale and Trim.

•	Repeat the process of duplicating the topmost graphic 
item and importing a new graphic for each of the 
remaining images in order so they correspond exactly 
with the thumbnail images. We currently have two 
target images imported, the others are:

	 3.	“birds at low tide.jpg”
	 4.	“footprints in wet sand.jpg”
	 5.	“groynes in winter.jpg“
	 6.	“low tide runnels in the sunlight.jpg”
	 7.	“marsh.jpg”
	 8.	“misty riverside.jpg”
	 9.	“wheeling gulls.jpg”

With all large graphic items created, we can apply the 
Target Image Action. This will control which large 

image is displayed when a particular thumbnail is 
clicked on.

•	Select an item in the stack of large graphic items and 
choose Item>Actions>Target Image. 

•	 If you don’t have the Actions palette open, choose 
Window>Actions to open it.

You will notice that the 
Target Image Action 
dialog is quite similar 
to the rollover dialog, 
in that each photo item 
appears in a list on the 
left (but there are far more 
columns). There are also 
check marks, which are 
currently all set in the 
Normal column.

Also, like the rollover 
dialog, there are two tab 
buttons, the first is called Images (which displays by 
default) and the other is called Parameters. 

•	To set up the following functionality you will need to 
make the Actions palette very wide.

•	Uncheck all the check marks in the Normal column and 
check them one at a time, in order, so a single check 
mark appears in each column (see screenshot on the 
following page). 

•	Give “beachhuts” a check mark in the Image 1 column, 
“weatheredseawall” a check mark in the Image 2 
column, and so on until you give a check mark for 
“wheelinggulls” in the Image 9 column. 

•	To finish off, also check the Normal column for the 
“wheelinggulls” item, as this is the image we want the 
visitor to see when they first open the page.



65

Tutorial

The image number columns are very important, as we 
need to choose the matching number for that target 
item in the Rollover Action dialog so it triggers the 
correct target. Because we did everything in order this 
isn’t an issue for now, but sometimes the numbers are 
worth noting down to make identification easier.

•	Click on the Parameters 
button.

•	Set the Restore pop-up 
menu to “No”.

This window may look a 
little daunting, but it really 
is quite simple. You can 
read more on what the 
options do in the Freeway 
Actions Guide.

Now we’ve assigned 
image numbers to our 
target images we can return 
to each thumbnail in 
turn to apply the rollover 
Parameter tab settings.

•	Select the first thumbnail 
and click on the 
Parameters button. 

•	Make sure the MouseOver 
popup is set to “Items”. 
The default is usually 
“None”.

•	Click on the Restore  
pop-up and choose 
“Sticky”.

•	Click on the MouseOver # 
popup and choose “1”.

We chose “Sticky” in the Restore menu so that the 
shadow thumbnail image and triggered large image 
remain displayed (even when the visitor mouses off 
the thumbnail) until another rollover on the page is 
triggered. 

•	Repeat this process for the eight remaining thumbnails 
to make them rollovers. The only difference is to set the 
Mouseover # to the number of the appropriate large 
target image (i.e., thumbnail 2 needs Mouseover # set 
to “2”, set thumbnail 3’s Mouseover # to “3”, etc., up 
to Image 9).
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•	Resample all graphics by choosing Edit>Resources... 
and click on Resample All. Click Done.

•	Choose File>Save to save the file.
•	Test the site in a browser by choosing a browser from 

File>Preview in Browser or click on the Browser 
button on Freeway’s tool bar to preview the page in the 
default browser you have set up.

When you move the mouse over a thumbnail, a 
shadow will appear (which remains when the mouse is 
moved away) and it also triggers a change of the large 
version of that same image below. If the rollover and 
target image don’t work as they should, check that the 
correct values have been used in the Action dialogs.

Other types of Action
So far we’ve introduced Item Actions, which are 
applied by selecting the item and choosing the Action 
from the Item>Actions menu. However, as stated 
before, there are other types of Action which are not 
item-specific. 

Let’s create a standalone (or “insert”) Action which 
displays the current date on a web page.

•	Click on the “Master1” Master page in the Site panel, 
go to Insert>Action Item and select Current Date 
from the list. This will place a small item on your page.

•	 In the top left-hand corner of the item is a box 
displaying the words “Current Date”. In the top right-
hand corner of the item is the Freeway Action cogwheel 
which signifies that this is an Action item.

•	 In the General tab of the Inspector, position and size 
the Action item using values X 10, Y 682, W 327 and  
H 12. 

You’ll notice that there is no content displayed in 
the item—this is because standalone Actions just 
generate task-specific code in your page when it’s 
published. This means that instead of you needing to 
add complex HTML code yourself, Freeway does it for 
you. The Current Date Action contains all the code 
necessary to display today’s date on your page, so all 
you need to do is position it where you want.

To see the Action working, you’ll need to preview the 
site in a browser.

•	Open the Actions palette so we can see the Current 
Date dialog.

•	You’ll notice that the only option available is whether 
or not you want to display the day of the week. Choose 
“Yes” from the pop-up menu.

Due to the simplicity of using standalone Actions, the 
text inside the item will use Freeway’s default font, size, 
color, etc. If you want to use custom styling for the 
standalone Action text, see the “Tip” panel below.

Styling Standalone Action items
If you have Freeway Pro you can simply select a 
standalone Action item and apply a custom CSS style to 
it from the Styles tab of the Inspector. However, styling 
a standalone Action item in Express (such as using a 
custom font, size, color, etc.) can only be done using a 
different method.

Express users need to insert the item “inflow” within 
an HTML item with a space each side. To do this, draw 
an HTML item on the page, click inside it (to see the 
flashing text cursor), type a space, go to Insert>Action 
item, choose the standalone Action you want to use 
and type another space. You can now select all (by 
going to Edit>Select All) so that both spaces and the 
Action item are selected, and then apply the styling 
you want to use in the General Settings tab of the 
Inspector.

! Tip
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When previewed in a browser, the Current Date 
Action displays as shown below.

Other types of Action—which we are not going to 
cover in this tutorial—include Page Actions and Folder 
Actions. To apply a Page Action, you need to select a 
page in the Site panel then go to Page>Page Actions 
to see the list of available Actions. Folder Actions 
can be applied by selecting a folder in the Site panel, 
opening the Actions palette and clicking on the “+” 
button in the bottom left corner. This will bring up a 
list of Actions that can be applied to the folder.

An example Page Action is the Sequence Timer 
Action which, when used in conjunction with the 
Target Image Action, can produce a changing sequence 

of images for which you can choose the order and 
timing of the sequence. 

Full details of the commonly used built-in Freeway 
Actions are covered later in the Freeway Actions Guide.

Third-party and additional Actions
It is often the case that there is a third-party Action 
which can be used  to achieve specific functionality 
quickly and easily—check the Softpress KnowledgeBase 
online (at http://www.softpress.com/kb) to see if there 
is an article covering the subject.

Third-party Actions, plus some very specific 
Actions not bundled with Freeway, can be found on 
ActionsForge—see http://www.actionsforge.com.

This concludes the tutorials on how to build a site 
with Freeway—hopefully you’ve been able to follow 
all the instructions and you’re now inspired to design 
a web site yourself.

The Tutorial section continues on the next page 
with how to upload a site which you have built 
yourself to the web so it can be seen by visitors using a 
web browser.
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Once you’ve finished working on your site, the next 
step is to upload it to the World Wide Web so that 
people can visit it. In most cases, Freeway manages all 
the files you’ve used on your site (as well as the pages 
themselves), so it’s a simple task to upload all required 
internal files using Freeway’s built-in upload facility.

This section naturally presumes that you already 
have an internet connection and a web hosting 
account which offers enough web space for your site.

Different ways to upload a site
There are two basic ways to upload your files so they 
are available to view on the web:

•	FTP (File Transfer Protocol), the most common 
method, which uploads files to you web host’s server.

•	File Copy, which is used if you run your own server 
on a network. Rather than uploading, this creates a 
copy of your site to a specified location.

Required information for FTP uploading
When you signed up with your web host, they 
should have sent you all the details of how to upload 
files to their server. Web hosts manage their servers 
in very different ways, so you will need to enter 
the information into the relevant fields exactly as 
instructed. Make sure you have this information to 
hand when you want to upload.

The following information should have been 
supplied by your web host:

•	Server: The address to where you need to upload the 
files. This is an FTP server where you will probably 
place your files within a directory specific to the web 
domain you wish to use as a web address.

•	Directory: The location on the server where your 
files need to be uploaded. This may be at the base 
level of the web domain’s directory (so it can be left 
blank), a specified directory (for example “ht_docs”, 
in which case you need to enter ht_docs in the 
Directory field, or it may be located one or more 
levels down (in which case you may be given a path 
name which consists of different directories separated 
by a forward slash symbol (“/”) for each level. Your 
web host may refer to this as the “Path” in your 
supplied uploading details.

	   If you receive “Error 550” messages when you try 
to upload your files to your server, it is likely that 
you are trying to upload the files into the base level 
of your server rather than the specific directory your 
host has told you to use.

•	User name: This is the User name given to you by 
the web host (not your computer’s user name). This 
is usually case-sensitive, so take care to enter the 
information exactly as it’s supplied with capital and 
lower case characters as appropriate. Your web host 
may refer to this as “User ID” or “Login Name”.

•	Password: As with your User name this is specific  
to your hosting account and will normally be  
case-sensitive.

There are some other options available in the Upload 
dialog box which we’ll cover later.

Uploading your site to the web
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Required information for uploading  
to a local server using File Copy
If you run a web server on your computer’s local 
network, you may need to enter the User name and 
password as supplied by your network administrator. 
You may also have been given a specific location in 
which to place your site’s files. 

You can also use Apple’s Personal Web Sharing to 
host your site. To do this, you’ll need to switch on 
Personal Web Sharing in the Sharing section of your 
System Preferences so that web sites in the “Sites” 
folder of your User folder can be visited on the web.

Whichever way you’ll be providing access to your 
site, you simply need to know the location of the folder 
that the web site should live in.

Uploading your files using FTP
As stated earlier, the most common way to upload 
files is to use FTP to send your files to your web host’s 
server.

To do this, choose File>Upload... which will open 
the Upload dialog box. In here, you’ll see the Upload 
pop-up menu which, by default, displays as “FTP”. If 
FTP is not displayed, choose it from the pop-up menu.

Enter the details exactly as they were supplied by 
your web host (see “Required information for FTP 
uploading” earlier in this section for more details).

Below the Password field is the Web address field, 
which is occasionally required when you’ve used a 
particular Freeway Action, such as the Freeway Shop 

Using Document Setup for upload info
If you prefer, you can set up all your upload 
information at any time by choosing File>Document 
Setup, then clicking on the Upload tab. 

This opens the same Upload dialog as displayed 
when you choose File>Upload. When you click OK, 
the information will be stored ready for when you want 
to upload the files to the web.

A more secure way to upload your site
Uploading your site by completing the Upload dialog 
and clicking OK allows Freeway to remember your User 
name and Password so it won’t be needed the next time 
you upload. However, this will mean that Freeway has 
stored that information (although it is encrypted) in 
your document.

A more secure method is to leave the Password 
field blank, which will result in a second dialog box 
displaying which requests your password when you 
click OK. This method ensures that only people who 
know the password can upload to your web hosting 
account.

! Tip

! Tip
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Actions. The instructions for the Action will tell you if 
you need to enter a web address here.

Below the Web Address field field is a popup called 
FTP Mode which, by default, will be set to Automatic. 
As stated earlier, web hosts work in different ways, so 
Freeway offers this facility as some hosts allow passive 
or non-passive mode to be switched on for uploads. 
If you experience difficulties with uploading using 
Automatic, try clicking on this popup and choosing 
Passive or Non-Passive manually.

Next is the Save log check box. This can be switched 
on to generate an error log which can often  
give information about why an upload has failed. If 
you’re experiencing upload problems, the Softpress 
Support department may ask you to switch this on 
so you can send an FTP log for further investigation. 
When checked, this saves a log file called “FTP log” in 
your User/Library/Logs folder.

When the fields have been completed, click OK to 
start the uploading process. Freeway will store the 
values you’ve used for subsequent uploads.

Uploading using File Copy
Choose File>Upload... to display the Upload dialog 
box, then choose File Copy from the Upload pop-up 
menu.

There are only two options available in the File Copy 
dialog box.

By default, the Upload to option will be set to the 
folder specified in the Sharing section of your System 
Preferences, but you can change this by clicking on the 
Select button, navigating to the location you want to 
use and clicking OK. 

The Web Address field serves the same purpose as it 
does for FTP upload.

Click OK to start the uploading process.

How files are uploaded
When you click OK in the Upload dialog, Freeway 
will check all the files in your Site Folder to see if 
any changes have been made since the site was last 
published. This ensures that the very latest version of 
your site will be uploaded. If changes have been made, 
Freeway will go through a republishing process before 
the upload begins.

This process will also remove any files no longer 
used by your site, which ensures that no unnecessary 
files are uploaded to your web server. While the 
republishing is taking place, Freeway displays the 
Progress dialog with the words “Building site”.
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When the republishing is complete, the Progress 

dialog closes and the Uploading dialog appears. 
Within this dialog, Freeway displays the number of 
items remaining to be uploaded and each individual 
item is specified at the foot of the dialog box.

name which consists of different folders separated by 
a forward slash symbol (“/”) for each level. Your web 
host may refer to this as the “Path” in your supplied 
uploading details. It is quite common for servers to 
use a specific folder called something like “ht_docs”, 
“html” or “www” (without the quotes)—and if so, 
you need to enter that name in the Directory field.

•	User name: This is the User name given to you by 
the web host (not your computer’s user name). This 
is usually case-sensitive, so take care to enter the 
information exactly as it’s supplied with capital and 
lower case characters as appropriate. Your web host 
may refer to this as “User ID” or “Login Name”.

•	Password: As with your User name this is specific 
to your hosting account and will normally be case-
sensitive.

If all the details appear to be correct, it might be 
that you entered them by copying and pasting from 
elsewhere (such as the email sent to you by your 
host) which might have also added some unnecessary 
characters, such as a space. Because Freeway will 
remember these details after the first time you upload, 
you only need to enter the details once—so perhaps it’s 
best to enter the details manually by typing them in.

Entering incorrect details in the Upload dialog will 
prevent the upload process from starting.

2. Use the Passive FTP Mode (PASV) option

By default, Freeway’s FTP dialog is set to “Automatic” 
for the FTP Mode popup. However, some web servers 
require that you use “passive mode” for uploading. 
If you find that the upload process started but then 
stalled, it might be that you need to use passive mode. 
Try uploading again, but this time click on the FTP 
Mode popup and choose “Passive”.

At any time you can stop the upload by clicking on 
the Stop button.

Troubleshooting upload problems
The upload function built into Freeway is very reliable 
and, although we receive some reported problems in 
Software Support, it is rarely a Freeway issue. If you 
have problems, work through the following in order:

1. Ensure you’re using the correct upload details

The details you need to enter in the relevant fields of 
the Upload dialog should have been sent to you by 
your host (usually in an email).

•	Server: The name of the server space where you need 
to upload the files. This is usually your domain name 
(such as www.mydomain.com), but you should check 
with the details sent to you by your host.

•	Directory: The location on the server where your files 
need to be uploaded. This may be at the base level of 
the web domain’s folder/directory (so it can be left 
blank), or it may be located one or more levels down 
(in which case you will have been given a “path” 
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Although it is far rarer than the need to choose 
Passive manually, it might be that your host requires 
you to choose Non-Passive in the FTP Mode popup—
so try this if you continue to have issues after using 
Automatic and Passive.

3. Check to see if it’s a Freeway issue

If you have followed the first two steps and the upload 
still doesn’t work correctly, it’s tempting to believe that 
it is a Freeway problem—but it seldom is. There are 
many reasons why the upload doesn’t work—perhaps 
the server is undergoing routine maintenance or there 
is a problem which your host is not aware of.

Another possibility is that you are running a firewall 
between your computer and the connection to your 
router. Check to make sure that the firewall is not 
preventing external connections to the web.

You can check to see if it is a problem with your 
server and not Freeway by attempting to connect to 
your server using a standalone FTP application (such 
as Cyberduck, Transmit or Fetch. Launch the FTP 
application of your choice) using the same details as 
you used in Freeway’s upload dialog.

If you can’t connect with the FTP application, then 
it is almost certainly a server issue—in which case you 
need to contact your host to see if there is a problem 
at their end (it’s also worth sending them the details 
you used to connect, so they can check that they are 
correct).

If you can connect successfully, try uploading your 
files with the FTP application. You can do this by 
opening your Freeway file’s Site Folder (the folder 
specified in the dialog if you go to File>Document 
Setup in Freeway), then dragging and dropping the 
contents into the FTP application’s upload window. 
Alternatively, you can use the File Copy method in 

Freeway’s Upload dialog to publish your site into a 
specified folder on your computer then dragging and 
dropping the contents of the specifies file copy folder 
into the upload window.

If the upload process stalls or you receive an error 
message, it might be because the server has “timed 
out”. If you are uploading very large files (such as 
QuickTime or MP3 files), a server connection may 
drop, so you may want to consider making the files 
smaller by using audio/video compression. Those using 
a dial-up connection need to realistic about the size of 
the files for upload if the server repeatedly times out.

If the problem persists, contact your host to see if 
there is a reason for the server connection to drop.

Uploading issues with sites using large 
video or audio files
Freeway does many different jobs very well—but it 
is not a specialist FTP application, and you may find 
that sometimes Freeway drops the connection if it 
mistakes the uploading of a single large file as a period 
of inactivity. This can result in Freeway terminating the 
connection to the server rather than leave your server 
open to spam or malware attack.

FTP applications do just one job—but they do that 
single job very well, and you may find that using a 
dedicated FTP app results in more reliable connections 
every time with no stalling or termination.

If this is the case, consider using the File Copy 
method to publish your files into a specified folder on 
your hard disk. You can then drag and drop the entire 
contents of that folder into the upload window of your 
FTP application. 

Modern FTP apps offer a “synchronization” function, 
so although all the files will be uploaded for the first 
time, you can synch what’s on the server with what’s in 
the file copy folder so for subsequent uploads only files 
required since the last upload was performed.

! Tip
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It is possible that there’s an issue with the connection 

itself—perhaps the Broadband connection is slow or 
unreliable. If this is the case, you need to report the 
problem to your telecoms provider.

In the rare event that you can complete an upload 
with an FTP application but can’t by using Freeway’s 
Upload function, contact our Support department at 
support@softpress.com and attach your FTP log (you 
can find in the User/Library/Logs folder after switching 
on the “Save log” option in Freeway’s Upload dialog).

4. The upload was successful but the site  
can’t be found on the web

If the upload process appears to have been successful 
but you can’t find the site on the web, it’s quite likely 
that you are uploading your files to the wrong location 
on the server. Check the details from your host again 
to see if they instruct you to use a specific folder 
(directory) on the server—if one is specified, enter the 
name of that folder in the Directory field of the Upload 
dialog.

You can use a dedicated FTP application to connect 
to the server to see if there is a particular folder in 
which you should be uploading your files to.

Another reason for your site not being accessible 
on the web is if your Home page doesn’t have the file 
name of “index.html”. Freeway by default should give 
your Home page (ie, the page which you see when you 
type in just your domain name in the URL address field 
of a browser) the file name of “index.html”—however, 
if you have been moving pages around in the Freeway 
file this might not be the case. Open up your Freeway 
file to see if your Home page has “index.html” in the 
File field in the Page Inspector—if it doesn’t, change it 
to “index.html” (without the quotes) and then upload 
again.

Dedicated FTP applications
Freeway’s FTP upload option has everything you 
need to upload your site to the Web server, and will 
automatically manage the files and delete files which 
are no longer needed. However, there are a few things 
that you might need to do which require a more 
comprehensive FTP tool.

Freeway will not delete any files that were previously 
on the FTP server—it will only overwrite them where 
necessary. This is because you might have some pages 
on the server which have been uploaded using another 
Freeway document or by someone else using a different 
web design application. When you upload a particular 
Freeway document, the only redundant files which will 
be deleted are those which formerly belonged to that 
document. You need to use a dedicated FTP application 
if you want delete specific files on the server or to 
remove an entire site.

When uploading your site, you may need to upload 
to a directory that doesn’t currently exist on the 
server—in which case, you need to use Cyberduck, 
Transmit or Fetch to create that directory on the FTP 
site first. You might want to do this if you want to 
upload a test site that doesn’t replace your own site 
or if you want to store Flash files or movie resources 
online.

The first step is to log on to the server using 
your chosen tool. In Cyberduck go to File>Open 
Connection, enter the details and click Connect; in 
Transmit select Connect to Server from the Go menu, 
enter then details then click Connect; in Fetch select 
New Connection from the File menu, enter the details 
and click on OK.
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Deleting files

Once connected, you’ll see a window showing the 
contents of the folder on the server. Here, you can 
delete files by clicking on them and following the 
deletion procedure for that particular application.

Creating a directory or folder

To create a new folder on your web server, you need to 
first navigate to the location where you want to create 
the new folder. In Cyberduck and Transmit, select New 
Folder from the File menu and enter the name for the 
new directory. In Fetch, select Create New Directory 
from the Directories menu.

External files

You might also need to use an FTP application to 
upload files which are not automatically uploaded by 
Freeway—for example referenced items required for a 
Flash slideshow, a Java applet, or a script you need to 
use on your site.

It is important to note that Freeway will not upload 
files that have not been imported into items on any 
of the pages of the site or chosen within an Action. 
This means that any required files which have been 

specified in custom markup code or referenced in Flash 
or Javascript files must be uploaded manually using an 
FTP application.

To do this, just log on to the server as described 
above then drag the item(s) from the Finder into the 
window for the appropriate directory to upload it.

Where to find FTP applications

There are many FTP applications available—you can 
find them on sites such as http://www.pure-mac.com 
or http://www.macupdate.com/find/mac/ftp

Some of these applications are freeware—such as 
Cyberduck, some are shareware—such as Captain FTP, 
while others are commercial applications, such as Fetch 
and Transmit. Below, we’ve added URLs to the more 
well-known and well-established ones, so you can 
check their use and license terms.

FTP applications.

Cyberduck (freeware): http://cyberduck.ch/
Fetch (commercial): http://fetchsoftworks.com/
Transmit (commercial): http://www.panic.com/

transmit/
Captain FTP (shareware): http://captainftp.xdsnet.de/
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Working with Freeway
This section is designed to give you an introduction 
to working with Freeway, brief instructions on how 
to perform common tasks, and also some tips about 
avoiding common pitfalls. As with much of the rest 
of this guide, it will be based around Freeway Express. 
There will also be Freeway Pro information present, 
and this will be marked as such where appropriate.

We will not cover such matters as starting and 
serializing Freeway here. These are covered in the earlier 
section of this guide entitled “Installing and Serializing 
Freeway”.

Before reading this section, you should have at 
least a passing familiarity with the various parts of 
the Freeway interface—there will be an assumption 
throughout that you are familiar with such terms as Site 
panel and Inspector palette. Brief introductions to all of 
these and more are present in the Quick Tour section to 
be found earlier in this guide.

Creating a new document
Once Freeway has been started, the first step to making 
a web site is to create a document. Generally, each 
web site you make will be contained within a single 
Freeway document.

New documents can be created in two different ways:

•	From a predefined template (including “Blank”).
•	From custom settings you specify when the 

document is created (Pro only).

By default, Freeway will open the New Document 
dialog when it is started. If this is the case, you can skip 
step 1 of the following instructions.

To create a document from a template

1.	Choose File>New…. This will open the New 
Document dialog. 

          Pro-only New Document tabs
The New Document dialog contains two sections, 
Templates and Custom. Select the Templates tab 
before proceeding to the next step.

Pro

2.	From the template group list on the left hand side of 
the dialog, select the category of template you wish 
to create a new document from.

3.	In the area on the right, you will see all the 
templates contained within the template group. 
Click on the template you would like to create a new 
document from.

4.	Click the OK button.
5.	A dialog will appear. Enter the name of your new 

document in the Save As field, and then navigate to 
the location in which your new Freeway document 
should be created.

6.	Click on the Save button.

Your new document will be created and it will display 
in the Freeway interface.

To create a document using custom settings  
(Pro only)

1.	Choose File>New…. This will open the New 
Document dialog.

2.	Select the Custom tab if it is not already selected.
3.	Edit the settings in the various fields in the dialog, or 

accept the default values. Site Folder, Resources 
and File Names are all settings related to the output 
of your web site. Default HTML and Default page 
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size are default settings for all new pages you will 
create in your document. All of these settings can be 
changed later from the Document Setup dialog.

4.	Click OK.

Your new document will display in the Freeway 
interface. Unlike creating a new document from a 
template, no file is saved to disk when creating a 
custom document in this way. That will not happen 
until you choose File>Save for the first time, 
File>Close or File>Quit.

The Freeway workflow, publishing,  
and previewing
The basic Freeway workflow is simple. Create pages. 
Add items to the pages. Insert content into the items. 
Publish. Upload. Of course, in reality, there are many 
more things that you’ll do within this basic framework, 
but this short description covers the major areas of 
activity. These are the areas which will be covered in 
the upcoming sections.

It is important to note that Freeway doesn’t generate 
any HTML code until you publish your web site, and 
indeed that this code and its associated resources 
(for instance published graphic files) are completely 
separate to the Freeway document itself.

To publish your web site, choose File>Publish Site. 
This will create all of the code required for all the pages 
in your site. Subsequent publishes will just update 
pages that have changed since the last publish.

You can also preview the current page you are 
working on within Freeway. This will automatically 
publish just the current page. To do this, click on 
the Preview button in the bar between the layout 
view and the tool bar. To preview your whole site in a 
browser, go to File>Preview in Browser and select 

one of the browsers listed there. This will publish your 
whole site if necessary.

To upload your web site

1.	 Choose File>Upload….
2.	 Choose the upload type from the Upload pop-up 

(this will depend on the type of web hosting you 
have).

3.	 Fill in the server and/or authentication details for 
the upload type you chose.

4.	 Click OK.

For further information pertaining to uploading, see 
the uploading section, located at the end of the tutorial 
section—it contains much greater detail about the 
upload settings, and common problems people have 
with uploading.

Working with pages
Pages in Freeway are the area upon which you place 
all of the content for your web site. The first and most 
important thing to know about pages is that there are 
two types of pages:

•	Master pages. These are pages upon which other 
pages in your Freeway document are based. These 
pages are never output.

•	Site pages. These are the pages which are actually 
output by Freeway and represent web pages in your 
web site. All site pages are based upon a master page.

Master and site pages can be seen in the site panel. 
All master pages can be found in the Master pages 
folder, above the separating line in the site panel. All 
site pages can be found below the separating line. The 
name of a site page in the site panel is followed in 
square brackets by the name of the master page upon 
which it is based.
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All items created on a master page are also created 
on site pages based on that master page. Changes 
to an item on a master page will be reflected in the 
equivalent items on the site pages. If you edit an item 
on a site page that is based on an item on a master 
page, it will no longer be updated when the item 
on the master page is changed. You can, however, 
reconnect it fully with the item on the master page 
by turning on both the Use Master Settings and 
Use Master Content checkboxes in the Properties 
section of the General tab in the Inspector palette for 
the item on the site page.

To create a new master page

1.	Choose Page>New Master….
2.	Enter the name for your new master page in the 

Title field.
3.	Click OK.

A new master page will be created using the default 
page settings for your document.

To create one or more new site pages

1.	Choose Page>New Pages….
2.	Enter the name for your new page in the Title field.
3.	Enter the number of pages you would like to create 

in the Pages field.
4.	Select the master page these new pages are to be 

based on from the Master pop-up menu.
5.	Click the OK button.

The new pages will be created using the settings of the 
master page you selected.

To delete a page

Click on it in the Site panel and press the Backspace/
Delete key.

Working with items
When working in Freeway, a large proportion of your 
time will be spent creating and modifying items. 
These are the containers within which you will place 
much of your content, and so it is really important 
to understand the different types of items, when it’s 
appropriate to use each type, and how the different 
types of item interact with each other on the page.

The principal types of item that can be created are:

•	HTML items. These are mostly used to contain 
HTML text. This should normally comprise the bulk 
of the textual content of your web pages. Using 
HTML text is important for a number of reasons, 
particularly the ability for search engines to read it 
and use it as a way of including your site in their 
search results.

•	Graphic items. These have two main purposes. 
Firstly, they’re often used to contain graphics, for 
example photos. Secondly, they can contain text, 
although this is best restricted to small amounts of 
text for headings and the like.

Although the two types of item are very different, they 
are created in the same way.

To create an item

1.	Select the button labeled HTML or Graphic in the 
tool bar.

2.	Move your cursor over Freeway’s layout view. You 
will see that the cursor is now a cross-hair.

3.	Click and hold the mouse button at the position on 
the page you want to start drawing your HTML item.

4.	Moving the cursor while continuing to hold down 
the mouse button will change the size of the item 
you are going to create. While doing this, Freeway 
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will show a live preview of the item as you draw it 
on the page.

5.	Once the item is the size you want it to be, release 
the mouse button.

Freeway will create the item and select it for you. You 
can tell an item is selected because it has small grey 
handles at the corners and at the mid-point of each 
side. These are called the selection handles. To select 
an item that is not currently selected, you can click 
on it in the layout view. To select multiple items, hold 
down the shift key while clicking on the other items.

You may want to change the position of the item 
after creating it. To do so you can simply drag it around 
in the layout view, or for finer control you can move 
the item using the arrow keys. To resize the item, you 
can drag one of the selection handles. If you hold 
down the Shift key while doing this, the item will 
be constrained to a square or a circle, or if you hold 
down Shift and Option, the item will maintain its 
proportions as it’s resized.

For more precise control over the position and size 
of an item, you can use the Dimensions section of the 
Inspector palette.

As well as being able to create rectangular graphic 
items, you can also create oval and path-based graphic 
items. Rectangular graphic items can be given round 
corners using the Shape section of the Appearance 
panel in the Inspector palette. There are also buttons 
in this section to convert a graphic item between 
rectangular, oval and path shapes.

To delete an item

Select an item and press the Backspace/Delete key.

Parent/Child relationships
In Freeway, some items can have a hierarchical 
relationship. Whether or not this is possible depends 
on the types of the items involved. This allows items to 
be grouped together as a single unit, and also enables 
advanced users to create more complex CSS-based 
layouts.

The hierarchical relationships between items on a page 
can be seen in the site panel, either when in Page view 
mode, or in the site view when Show Items has been 
selected from the cogwheel pop-up below the site panel.

These relationships can also be seen more 
immediately in the layout view. 
When an item is selected, its 
parent’s border is highlighted 
with the system highlight color, 
and its children’s borders are 
highlighted in grey.

Items can also be a child of 
the page, which is how they 
are created unless you use the 
following method.

             CSS Layout (Pro Only): IMPORTANT
In Freeway Pro, it is very important to know that there 
are two different layout models that you can use in 
your pages, table-based layout and CSS layout. The 
default type of layout used for new items that you draw 
on your page is controlled by the large round button in 
the tool bar containing the letters CSS.

The type of layout that you use will have a 
significant effect on the way your page is output, and 
also the way it behaves in the browser. Both methods 
have their advantages and disadvantages. To find out 
more information about these and other issues relating 
to the two types of layout, see the Freeway 5 Reference.

Pro
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To create an item that is the child of another 
item

1.	Select the item tool appropriate to the type of item 
you would like to create

2.	Start and finish drawing within another item that 
is of a type that can be a parent of the item you’re 
creating. You will see that the item that will become 
the parent is highlighted while you are drawing the 
item.

To make an existing item a child of another item

1.	Start dragging the item you want to make a child
2.	Move it over the item you want to make the new 

parent of the item you are dragging
3.	Press the space bar once. This will highlight the new 

parent item.
4.	Finish dragging by releasing the mouse button. The 

item will become a child of the new parent.

If there is more than one potential parent item 
underneath the item as it is being dragged, you can 
cycle through the potential parents by repeatedly 
pressing the space bar. Note that the page is also a 
potential ancestor and will be included in this cycle.

You may also want to group a selection of items by 
creating a new parent item to contain them.

To group several items together

1.	Select all the items you would like to make a group.
2.	Choose Item>Group.

This will create a new parent item containing all the 
items you selected.

To ungroup items

1.	Select the item created when the items were grouped 
(their parent).

2.	Choose Item>Ungroup.

Aligning and distributing items
It is very useful to be able to position several items at 
the same horizontal or vertical location, or to spread 
them out evenly.

To align several items

1.	Select all the items you would like to align.
2.	Choose Item>Align….
3.	This will bring up a dialog with several alignment 

options. The left-most button 
in each row represents a 
choice of no alignment. 
The other buttons represent 
possible horizontal or 
vertical alignments. Choose 
a horizontal and/or vertical 
alignment and click OK.

To spread items out evenly, you can use Distribute. 
Distributing items is the same basic process as aligning, 
but you choose Item>Distribute… instead.
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Manipulating items
As already mentioned, items can be positioned and 
resized in different ways. As well as this, items can be 
automatically resized to the size of their content, be it 
text or graphic.

To resize an item to fit its content

1.	Select the item you would like to resize.
2.	Choose Item>Fit Box to Content.

There are extra manipulation options available for 
graphic items, for example rotation.

To rotate a graphic item

1.	Select the graphic item you would like to rotate.
2.	Select the rotation tool from the tool bar.
3.	Grab one of the item’s selection handles with the 

rotation tool.
4.	Move the cursor to rotate the item.
5.	Release the mouse button to complete the rotation.

Changing an item’s appearance
There are many ways of customizing the appearance of 
items in Freeway. There are also different methods of 
doing so dependent on the type of item. This will be 
touched on only briefly here but most options are easy 
to understand, so feel free to experiment.

For both HTML and graphic items, much of the 
appearance information for the item is available in 
the Appearance tab of the Inspector palette. Because 
it is such a common thing to want to modify, the 
background color of an item can also be changed from 
the General tab of the Inspector palette.

To set the background color of an item

1.	 Select the item.
2.	 In the Properties section on the General tab of 

the Inspector palette, click on the Color pop-up.
3.	 Select a color from the pop-up menu, or select 

Other… to use a color not already present in your 
document.

Changing how an item will output
The Output tab of the Inspector palette has a number 
of settings depending on the type of the item you have 
selected, and it will also allow you to change the type 
of the item. These settings allow you to have more 
control about how a particular item will be output 
when Freeway publishes it.

To change the type of an item

1.	 Select the item and switch to the Output tab of the 
Inspector palette.

2.	 Choose the new type of the item from the Type 
pop-up.

             Manipulating items in Freeway Pro
Freeway Pro allows you to skew and mirror graphic 
items. These transformations have their own tools 
which can be accessed by clicking and holding on 
the rotation tool in the tool bar and selecting the 
appropriate tool from the pop-up menu. The tools, 
once selected, are used in the same way as the rotation 
tool.

Freeway Pro also has a Transform dialog to allow 
you to apply transformations more accurately. This 
can be accessed by selecting an item and choosing 
Item>Transform….

Pro
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There are three different graphic item types that can 
be selected in the Type pop-up, JPEG, GIF, and PNG. 
These refer to the type of graphic created when Freeway 
outputs the graphic item, and each have their own 
strengths and weaknesses. When you import a graphic 
into a graphic item, Freeway will analyze the graphic 
and make an informed decision as to which type is 
best and set the graphic item to output using that type. 
You can use these options to override Freeway’s default 
judgement if you want.

There are also different settings available for each of 
the graphic types that will allow you to fine tune how 
Freeway outputs that particular graphic.

To set the alt text of a graphic item

1.	 Select the graphic item and switch to the Output 
tab of the Inspector palette.

2.	 Ensure the Alt Text 
checkbox is on and then 
enter a description of 
the graphic into the field 
beneath the checkbox.

Alt text is important because 
it will allow people who 
cannot see the graphic to see a 
description of the image. This 
include people using screen 
readers and also anyone using 
a simple text-based browser.

Working with Tables
Tables should mainly be used for presenting tabular 
data. It’s unnecessary to use them for positioning 
purposes—just use Freeway’s items instead. The Table 
tool is in the Freeway Pro tool bar by default, but in 
Freeway Express you will need to customize your tool 
bar, or open the pop-up menu on the HTML tool on 
the tool bar and select the table tool from there.

After selecting the table tool, you can draw them 
exactly as you would any other item. Once you’ve 
finished drawing a table, you will be prompted to 
choose the number of rows and columns the table 
should contain.

To select the table, click on the border at the edge of 
the table. You can select table cells in the same way as 
you would an item, and entering text works the same 
way as well. You can also select multiple table cells 
in the same way as you would select multiple items. 
To select a whole column or row, position the cursor 
at the top of a column or to the left of a row. It will 
change to be an arrow pointing at the column or row, 
and clicking will select all the cells in the column or 
row it is pointing to.
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To resize a column or row in a table

1.	 Position the cursor at the bottom of the row, or to 
the right of the column, you want 
to resize. It will change appearance 
when you are in the correct place.

2.	 Click and drag to resize the column 
or row.

To change the number of rows or columns  
in a table

1.	 Select the table.
2.	 Switch to the General tab of the Inspector palette.
3.	 In the Cells panel, enter new values into the Rows 

and Cols fields.

You can also use the Item>Table menu to insert and 
delete columns.

To merge cells into one

1.	 Select the cells you want to combine into one.
2.	 Choose Item>Table>Join Cells.

To split cells

1.	 Select the cells you want to split
2.	 Choose Item>Table>Split Cells….
3.	 Select whether to split the cells into rows or 

columns, and enter a number of rows or columns to 
split them into.

4.	 Click on OK.

Working with colors
All Freeway documents are created with a basic set of 
colors. As you assign colors to elements and text within 
your document, Freeway will add these colors to the 
documents color list. This means that they will then 

be available in all the lists from which you can select 
colors. Colors are removed from the color list once 
they are no longer being used in the document.

Colors in Freeway Express
In Freeway Express, colors 
do not have names and 
are simply presented as 
swatches in the color pop-
ups throughout the Freeway 
Express user interface. 

Clicking on the color popup 
in the Inspector will show you 
the list of colors already in 
use in your document. If you 
want to choose a new color 
which is not already in the 
color list, choose Other... at 
the top of the popup list.

The color palette is the Mac OS X system color 
palette that you may be familiar with from other 
applications, for example TextEdit.

To apply a new color using the color palette  
in Freeway Express

1.	 Select the page, item or text you want to apply color 
to.

2.	 Select the appropriate tab in the Color palette (for 
example Color Sliders) and choose the swatch 
from the popup if there is a choice.

3.	 Edit or click on the color you want to use. As you 
edit or click on colors, the color of the selected 
element in Freeway will change accordingly.
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Colors in Freeway Pro
Freeway Pro has far more advanced color handling 
than Freeway Express. Every color is named and 
permanent colors can be created that exist even if 
they are not applied anywhere in the document (the 
concept of temporary and permanent entities will 
come up again when discussing Styles in Freeway Pro).

Editing a color in Freeway Pro will change all 
occurrences of that color within your document. This 
makes it very easy to make wide-ranging changes to the 
color scheme of your web site.

The Color palette in Freeway Pro is actually part of 
the Styles and colors palette. There are two tabs in 
this palette related to colors, the Document colors tab 
and the Web-safe colors tab.

The Document colors tab contains a list of all the 
colors within your document. This includes the default 

set of colors, temporary colors created as you have 
assigned colors to objects and text in your document, 
and any permanent colors that you have created. The 
Web-safe colors tab contains colors that should 
display accurately on most color monitors.

To apply a color that is already in the Colors 
palette of Freeway Pro

1.	 Select the page, item or text you want to apply color 
to.

2.	 Select either the Document colors tab (second 
from the left at the top of the palette).

3.	 Choose on the color you want to use from the list.

To apply a color that is not already in your 
document using the color palette

1.	 Select the page, item or text you want to apply color 
to.

2.	 Click on the cogwheel at the top of the palette and 
select Color Picker… from the pop-up.

3.	 Choose the color you want to use from the system 
color palette and click OK.

To add a new 
color to the color 
palette

1.	 Select either 
the Document 
colors or the  
Web-safe 
colors tab in 
the Styles and 
colors palette.

2.	 Click on the 
cogwheel at the 

The Freeway Pro Color dialog 
when choosing Other... in the 
Inspector.

Document colors in 
the Styles and Colors 
palette
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top of the palette and select New Color… from the 
pop-up.

3.	 Enter a name for the color in the Name field.
4.	 Select a color from the swatches of the system color 

palette.
5.	 Click OK.

To edit a color

1.	 Control-click on the color to edit in the Document 
colors list in the 
Styles and colors 
palette.

2.	 Select Edit Color… 
from the pop-up.

3.	 Change the color 
using the same 
method as for a new 
color.

4.	 Click OK.

To delete a color

1.	 Control-click 
on the color to 
delete in the 
Document 
colors list in 
the Styles and 
colors palette.

2.	 Select Delete 
Color from the 
pop-up.

3.	 If the color is 
used in your document, you will be asked to select a 
color to replace it with. Choose one and click OK.

It is worth noting that none of the built-in colors (the 
colors available in every new document) can be edited 
or deleted.

Colors can also be managed and imported in the 
Edit Colors dialog which can be accessed by choosing 
Edit>Colors…

Working with graphics
One of the most common tasks within Freeway is 
adding and manipulating graphics within a site. 
Graphics within Freeway are contained within an item. 
If the item is a graphic item, Freeway will optimize 
the graphic for you when you publish your site. If 
the item is an HTML item, the graphic will be output 
unchanged; this is called a “passthrough graphic”.

Graphics that are contained within graphic items can 
also be scaled and cropped. Filters can be applied to 
the graphic using a variety of graphic Actions. HTML 
items that contain graphics must be at least as large as 
the graphic if the graphic is to be output; if the item 
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is not large enough, Freeway will show 
you by “overflowing” the item—placing 
an X through it and not displaying the 
graphic. Resizing the item appropriately 
will fix this problem; an easy way to 
do this is to choose Item>Fit Box to 
Content.

To import a graphic into an existing item

1.	Select the item to import a graphic into (ensure 
it does not contain text; if you want to import a 
graphic into an item containing text, you will need 
to delete all the text first).

2.	Choose File>Import….
3.	Locate the graphic file you would like to import and 

click OK.

Freeway Express can import GIF, JPEG and PNG files. 
Freeway Pro can import a far greater range of graphic 
types, including Photoshop and Illustrator files, 
although these should only be imported into graphic 
items because they need to be converted to a web-ready 
format to be displayed in your web page.

You can also drag a graphic directly from the Finder 
onto your Freeway page. You can either drag it into 
an existing item, or directly onto the page, in which 
case a new graphic item will be created to contain 
it. Alternatively, a new HTML item can be created to 
contain the graphic if you hold down the Option key 
when dropping it onto the page.

Manipulating graphics in graphic items
Once you have added a graphic to your page, you can 
manipulate it in a variety of ways.

To position a graphic within its containing item

1.	Position the cursor over the arrows in the center of 
the graphic item. These 
are called the panning 
handles and the cursor 
will change to a hand 
when it’s positioned 
over them.

2.	Hold down the mouse 
button and drag the graphic around within the item.

3.	Let go of the mouse button when the graphic is 
positioned as you want it.

To scale a graphic to the size of its containing 
item

1.	Select the item containing the graphic.
2.	Choose Item>Graphic>Scale to Box.

This will scale the graphic without maintaining its 
proportions. This menu contains other options for 
scaling including Scale and Pad and Scale and Trim, 
both of which maintain the proportions of the graphic 
but result in different sized graphics. There is also the 
option to increase and decrease the size of the graphic 
in increments by using Scale Up and Scale Down.

If you hold down the Shift and Option keys 
while resizing a graphic item to maintain the item’s 
proportions, any graphic contained within it will also 
be resized maintaining its proportions.

Whenever you scale graphics, it is a good idea to 
resample them afterwards. The main advantage of this 
is to reduce the size of Freeway’s internal version of the 
graphic. This will help reduce the size of your Freeway 
document.
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Working with other media
As well as being able to import graphics into HTML 
items, you can also import all sorts of other media. 
Other types of media that you can import include 
Flash, QuickTime movies and mp3 audio files. You 
import media files using the same method as if you 
were importing a graphic into an HTML item.

If you’re importing Flash or QuickTime movies, 
you may want to have a look at the Flash Extras or 
QuickTime Extras Actions which can modify the way 
these files behave when viewed in a browser.

Working with text
As discussed earlier, text within HTML items and 
graphic items are generally used for very different 
purposes. However, working with the text in either 
type of item is essentially the same, although you will 
notice as you work with text that some of the available 
options are different. It is also possible to enter text 
directly into the page.

To enter text into an item

1.	Select an item that does not contain a graphic by 
clicking on it.

2.	Click on the item again.

This will insert a text cursor into the box, and you can 
now type text freely within it. To enter text directly 
into the page, double-click on it in the layout view. 
Once you’ve finished editing text within an item or 
the page, click outside the item or page to leave text 
editing mode.

As well as entering text directly using the keyboard, 
text can be imported into an item from a text file.

To import text from a file into an item or page

1.	 Get a text cursor in the item or page you wish to 
import text into (as described earlier).

2.	 If there is existing text in the item, position the 
cursor where you want to add the text you are 
importing.

3.	 Choose File>Import Text….
4.	 Find and select the text file whose content you 

would like to import and click OK.

Styling text
Applying styling to text is a fundamental part of 
creating any web site. In Freeway, most styling of text is 
done from one of two places. The first is the Inspector 
palette, and the second is the Style menu. The options 
available for styling text in the Inspector palette are a 
subset of the options available in the Style menu.

The Inspector’s 
Style palette.

The Style 
menu.



88

W
or

ki
ng

 w
ith

 F
re

ew
ay

Selecting text and applying styling in Freeway works 
in the same way as most other applications. Select 
the text you want to style and change the appropriate 
attribute in either the Inspector or the Style menu.

Text styling attributes are divided into character 
and paragraph attributes. Character attributes (for 
example font and color) can be applied to any run of 
text. Paragraph attributes (for example alignment) will 
be applied to the whole of any paragraph contained 
within the current text selection.

To remove styling from text

1.	 Select the text you want to remove all styling from.
2.	 Choose Style>Remove Styling.

This will remove all character attributes from the 
selected text. Paragraph attributes will only be 
removed from paragraphs that are completely 
selected, including the hidden paragraph character 
at the end of each paragraph—you can see hidden 
characters if you choose View>Invisibles (the last 
paragraph has no hidden paragraph character, so there 
is no need to select it). The easiest way to select a 
complete paragraph is to click on it four times in quick 
succession (quadruple-clicking).

Working with lists
As well as being useful for creating hierarchical HTML 
lists within text in your document, lists are used 
extensively in the CSS Menus Action. They are created 
by converting paragraphs of text into list items.

To create a list

1.	 Select one or more paragraphs you want to make 
into a list.

2.	 Choose Style>List>Increase indent.

or

1.	 Select one or more paragraphs you want to make 
into a list.

2.	 Click once on the Right Arrow in the Links panel 
of the Inspector.

To change a list item back into a paragraph, select the 
list item and choose Style>List>Decrease indent. 
To create a nested list, select a list item and choose 
Style>List>Increase indent. The first list item in a 
list cannot have its indent increased.

Inserting items into a text flow
An important technique to know about when working 
with HTML text is the ability to insert both HTML and 
graphic items into the flow of the text. This means that 
the items will move around as the text is reflowed by, 
for example, different people having different settings 
in their browsers for the text size. These are called  
“in-flow items”.

To insert a graphic item into an HTML text flow

1.	 Select an item containing text and click again on it 
to get a text cursor within it

2.	 Position the cursor at the point in the text where 
you want to add the graphic item

3.	 Choose Insert>Graphic Item.

A default-sized graphic item will be inserted into the 
flow of text. This item will behave just as a graphic 
item you had drawn on the page would behave. 
The only major difference is that you can no longer 
position the item – its position is determined by the 
text around it. You can of course still resize it in the 
same way as an item you had drawn on the page.
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There is also an Align setting 
in the Dimensions panel 
of the Inspector palette for 
in-flow graphic items. This 
allows you to position the 
graphic item vertically relative to the rest of the line of 
text it is within, or to force it to the left or right of its 
containing item and have the text flow around it (the 
Left and Right settings in the Align pop-up).

To insert an HTML item into a text flow

1.	 Select an item containing text and click on it again 
to get a text cursor within it.

2.	 Position the cursor at the point in the text where 
you want to add the HTML item.

3.	 Choose Insert>HTML item.

A default-sized HTML item will be inserted into the 
flow of text. You will notice however that in-flow 
HTML items always exist within their own paragraph 
in a text flow. HTML items can also be set to have the 
text flow around them; simply choose Left or Right 
from the Float pop-up in the Dimensions panel in 
the Inspector palette.

Freeway Pro provides you with many ways to create 
in-flow layout. In-flow layout is important for creating 
web sites that are flexible and work well with the  
different setups people have in their browsers, for 
example (as has already been mentioned), having 

different text sizes specified, or their browser window 
at different widths.

Following are just a couple of ways to modify in-flow 
HTML items in Freeway Pro. Further information is 
available in the Freeway 5 Reference.

To center an in-flow HTML item within its 
containing item (Pro only)

1.	 Select the in-flow HTML item and switch to the 
General tab of the Inspector palette.

2.	 In the Dimensions panel, ensure that the Float 
pop-up is set to None

3.	 Open the Margin pop-up, choose Custom..., click 
on the Align popup and select Center.

To set an in-flow HTML item to always be the 
width of its containing item (Pro only)

1.	 Select the in-flow HTML item and switch to the 
General tab of the Inspector palette.

2.	 In the Dimensions panel, click on the Width 
button (ie, the button immediately to the left of the 
Width field) or delete the contents of the Width 
field and press the Return or Tab key.

Working with Styles 

One of the major advantages of Freeway Pro is being 
able to group a set of character and paragraph style 
attributes into a single style. Once created, a style can 
be applied to any text in your document, making it 
easy to use consistent text styling across your whole 
site. An extra bonus is that you can edit the style and 
any changes you make will apply to all the text in your 
document that is using the style.

Pro only
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Document styles you 
created are displayed in 
the Document styles tab 
of the Styles and Colors 
palette. There are also some 
default styles automatically 
added to new documents, 
and a [No Style] that, 
when clicked on, will 
behave in the same way as 
choosing Style>Remove Styling.

To create a new style

1.	 Switch to the Document styles tab of the Styles 
and Colors palette.

2.	 Click on the cogwheel, and in the pop-up menu 
select New Style….

3.	 In the New Style dialog, add style attributes for 
this style by clicking on the plus button to the right 
of the section for the type of attribute you want 

to add, then selecting the 
attribute from the pop-up 
menu.

4.	 Set values for the attributes 
after you’ve added them.

5.	 Name your new style by 
entering text in the Name 
field.

6.	 Click on OK.

While in the dialog, you can 
remove an attribute by clicking on the minus button 
next to it.

To edit an existing style

1.	 Switch to the Document styles tab of the Styles 
and Colors palette.

2.	 Control-click on the style you want to edit in the 
styles list, and select Edit Style… from the pop-up 
menu.

The Edit Style dialog works in the same way as the 
New Style dialog. There is also an Edit Styles dialog 
which can be opened by choosing Edit>Styles…. This 
dialog is much the same as the two dialogs you have 
already seen, but also has a list of all document styles 
on the left hand side. This allows multiple styles to be 
edited at a time.

To apply a style to text

1.	 Select the text you want to apply the style to.
2.	 Switch to the Document styles tab of the Styles 

and Colors palette.
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3.	 Click on the style in the list you want to apply.

To delete a style

1.	 Switch to the Document styles tab of the Styles 
and Colors palette

2.	 Control-click on the style you want to edit in the 
styles list, and select Delete Style from the pop-up 
menu.

If the style is being used anywhere in your document, 
a dialog will appear prompting you to choose another 
style to replace it with. If you want to remove the style 
from your document and from all the text it is used on, 
choose No Style from the list in this dialog.

As well as being applied to text, styles can be applied 
to items and pages so they style all the text within the 
item or page. You can see which styles are active for 
the current selection in the Style Inspector tab of the 
Inspector.

Permanent and temporary styles

In Freeway Pro, when you style text using the Inspector 
palette and the Style menu, temporary styles will be 
created. These are styles that only exist while text exists 
with their styling applied. New temporary styles will 
be created and existing ones deleted as you change 
the styling of text within your document using the 
Inspector palette and Style menu.

Although these styles can be useful, it is generally far 
better to use permanent styles when possible. These 
are the styles you create manually using, for example, 
the New Style dialog. These styles are permanent 
by default, meaning that they will remain in your 
document whether or not they are applied to any 
text. If you have styled some text using temporary 

styling, you can change the temporary style into a 
permanent style by editing the style and turning on 
the Permanent checkbox.

Permanent styles are shown in bold text in the Styles 
and Colors palette.

Hyperlinks and anchors
Hyperlinks provide a way for people visiting your site 
to navigate to other pages within it, or to another web 
site entirely. Anchors are a way of tagging a particular 
object on a page so that when you click on a link to it, 
you’ll be taken to the appropriate page and the browser 
will scroll to the position of the tagged object.

To create a hyperlink

1.	 Select a graphic item, map area, some graphic text 
or some HTML text. Choose Edit>Hyperlink….

2.	 Click on the Internal tab and select a page from 
the list to create a link within your web site, or click 
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on External and enter the URL to create a link to a 
different web site.

3.	 Click OK.

To remove a hyperlink

1.	 Select a graphic item, map area, some graphic text 
or some HTML text that has a link applied.

2.	 Choose Edit>Hyperlink….
3.	 Click the Remove Link button.

To create an anchor

1.	 Select a graphic item or some HTML text.
2.	 Choose Edit>Anchor….
3.	 Enter a name for the anchor in the Name field.
4.	 Click OK.

To remove an anchor

1.	 Select a graphic item or some HTML text that has 
an anchor applied.

2.	 Choose Edit>Anchor….
3.	 Click the Remove Anchor button.

When creating an internal hyperlink, the anchors on 
the page you have chosen to link to are shown in the  
Anchor pop-up on the Internal tab underneath the 
list of pages.

Working with HTML forms
Each site page in Freeway can have a HTML form on 
it. There are two steps to setting up a form in Freeway. 
Firstly, you need to place controls on the page and 
secondly, you need to set up the form’s properties.

Form controls are created just as you would any 
other item, but you first need to select the appropriate 
drawing tool. By default, the form control drawing 
tools are located in the HTML tool popup on the tool 
bar.

To set up the form properties for the current 
page:

1.	 Choose Page>Form Setup….
2.	 In the Form tab, select a form submission method 

from the Method popup.
3.	 Enter the URL of the form processing script into the 

Action field.
4.	 Click OK.

Don’t forget 
that you need to 
add a Submit 
button for people 
to click on to 
send the form to 
your script for 
processing. Note 
also that the Action field should only have a URL for 
the processing script entered, not the contents of the 
script itself.

The simplest method for creating reply forms is to 
use the PHP Feedback Form Action—see the movie 
tutorial at http://www.softpress.com/support/tutorials.
html (the movie is called “Easy Feedback Forms”). Note 
that if you use this Action you should not use any 
information in the Form Setup dialog.

Only one form can be set up per page. If you want 
more than one form on your page, use the Multiple 
Form Suite from ActionsForge at http://www.
actionsforge.com/projects/view/24-multiple-form-suite

Further information
This completes the overview of basic functionality in 
Freeway. For more complete information on all of these 
topics, please consult the Softpress Knowledgebase.
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What are Freeway Actions?
Both Freeway Pro and Freeway Express ship with a 
comprehensive set of Actions which you can use to add 
functionality and dynamic effects to Web pages—some 
of which we’ve already used in the Tutorial section.

This section gives information on commonly-used 
“standard” Actions which come pre-installed, however 
many custom Actions can be downloaded free from 
ActionsForge (http://www.actionsforge.com). Other 
Actions, particularly complex ones, may be sold 
commercially on a developer’s web site.

Actions are comparable to plug-in modules, allowing 
you to add functionality or effects through the 
simplicity of an intuitive dialog box which would 
otherwise require sophisticated coding or repetitive 
formatting in other programs. An Action can be used 
for doing something as simple as making an image 
change color when a visitor mouses over it, or as 
complex as controlling forms and creating navigation 
bars. Others are part of a suite of Actions allowing 
you to create, for example, an on-line shop or sets of 
transition effects.

As stated earlier, this section will cover the standard 
pre-installed Actions, however Freeway Pro allows you 
to add further custom Actions which enhance the 
functionality of your web pages. Freeway Express only 
allows you to add Actions which have been encoded, 
so consult each Action’s documentation to see if it will 
work with Express. The download page for all Actions 
at ActionsForge gives details of which versions of 
Freeway any particular 
Action is compatible 
with. 

The different types of Actions
Because there are different types of functionality you 
may want on your site, there are different ways to 
apply an Action in Freeway. The different types of 
Action are:

•	Item Actions: The most commonly-used Actions, 
which are applied to a specific item (or group of 
items) on your page. Note that some actions are 
specific to HTML items and others are only for 
graphic items.

•	Page Actions: These are used on individual pages to 
apply functionality to the page itself.

•	Standalone Actions: Another commonly-used type 
of Action, which creates a pre-coded HTML item on 
your page (sometimes called “insert” Actions).

•	Folder Actions: These are used for applying an Action 
on a group of pages stored in a single folder. If all 
your site pages are stored in one folder, this can be 
used to apply site-wide functionality.

•	Suites of Actions: Complex suites of many different 
types of Action. The individual Actions within the  
suite can be any of the above Action types. The  
Actions work together to provide functionality in 
your web site.

Applying Actions
Before you apply an Action, it’s best to have the 
Actions palette open so you can see that the 
Action has been applied. If it’s not open, choose 
Window>Actions.

The way in which you apply an Action depends on 
the type of Action you want to apply:

94
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•	Item Actions: Select the item, choose Item>Action 

and select an Action from the list.
•	Page Actions: Select the page you want to apply an 

Action to in the Site panel, then choose Page>Page 
Actions and select an Action from the list.

•	Standalone/Insert Actions: Click and hold on the 
Action tool on the tool bar, choose the Action you 
want, then draw the Action on the page in the same 
way as you draw an item on the page. Alternatively, 
go to Insert>Actions and choose the Action you 
want. This method allows you to insert an Action 
into a text flow.

•	Folder Actions: Select a folder in the Site panel, click 
on the plus button in the bottom left corner of the 
Actions palette, then choose the folder Action you 
want to use.

In fact, all Actions can be applied using the plus button 
in the Actions palette. Clicking on it will show a list 
of all Actions which can be applied to the currently 
selected object.

The Actions palette
When no Actions have been applied to a selected item, 
page or folder, the Actions palette will be empty. To 
see how it works, let’s draw a graphic item on the page 
then apply an Action.

Click on the Graphic 
tool on the tool bar 
and draw an item on 
your page. With the 
item selected, choose 
Item>Actions and select 
Buttons from the list.

You will now see that a tabbed panel has appeared 
under the title bar entitled “Buttons” and, within the 
panel, the various options of the Action are displayed. 
Depending on which Action you apply, the options 
may take the form of text fields, check boxes, pop-up 
menus, etc., but the options will always be specific to 
that particular Action.

An item can have more than one Action applied at a 
time, so let’s apply another one. Choose Item>Actions 
and select Fade. You’ll see in the Actions palette that 
we now have two tabbed panels, the latest of which is 
now selected.

If you want to return to the Buttons Action, you’ll 
need to click on the Buttons tab.

Let’s apply a third Action. Choose Item>Actions and 
select Rollover. A third tabbed panel has appeared in 
the Actions palette, but this is a different type of panel 
in that it has more than one window which can be 
selected by clicking on the relevant button below the 
Actions tabs. The Rollover Action is currently showing 
the “Images” window. Clicking on the “Parameters” 
button displays a second panel of options.

Although there are two separate windows, both are 
specific to the Rollover 
Action. This is done 
because some Actions 
have very different 
types of options 
which don’t lend 
themselves to being 
displayed in the same 
window. In this case, 
the “Images” window 
displays the options in 
a table-based layout, 
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while the “Parameters” window is made up of a list of 
pop-up menus.

If you want to remove an Action from an item, 
simply click on the X in a circle to the left of the 
Action’s name.

You may also have noticed that each time an Action 
was applied to the item on the page, a label displaying 
the name of the Action appeared in the top left corner 
of the item’s container. With all three Actions applied, 
three labels appeared underneath each other, giving 
a quick visual reference to which Actions have been 
applied.

When an Action has been used, the Action cog logo 
will appear on the item, page or folder icon in the Site 
panel. This is a visual cue that it has an Action applied 
to it.

Installing new Actions
Once you have downloaded new Actions, they are 
simple to install. Drag the Action file onto the Freeway 
application icon (either in the Applications folder or 
in the Dock), and Freeway will start and inform you 
that you are about to install an Action. Click on the 
OK button to confirm that you want to install the 
new Action. Freeway will copy the Action file to the 
appropriate place on your hard drive.

It is important to remember that Freeway Express can 
only use encoded Actions. These are marked as being 
specifically for Freeway Express on the download page 
for that Action on the ActionsForge site or in the text 
of a developer’s web site.

If a page Action has been applied, the Actions palette 
will only display the options for that Action if no items 
are selected on the page.
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Because there are so many Freeway Actions, we 
don’t have the space here to cover them all, so we’ll 
concentrate on the most commonly-used ones. You 
can find out more on Actions not mentioned here in 
the Freeway 5 Reference, on the Softpress KnowledgeBase 
or at ActionsForge.

Here, we’ll see how to use common Actions, what 
options are available and also discuss typical problems 
users may have with particular Actions.

The Rollover Action
Perhaps the most common of all Actions is the rollover. 
Rollovers are graphic items in a stack which change to 
display a different graphic in the stack for each of the 
“normal”, “mouseover” and “click” states when the 
page is previewed.

There is a full tutorial on how to create a rollover in 
the Tutorial section (Tutorial 3), but because rollovers 
are so common we’ll run through a basic step-by-step 
here to explain the basic principles again:

1.	 Click on the Graphic tool in the tool bar, draw a 
wide rectangular item on your page, then apply a 
red background color in the Inspector.

2.	 Control-click (or right-click) and choose Duplicate 
from the contextual menu. Set the values of 1 for 
copies and 0px for horizontal and vertical offsets, 
click OK and then apply a green background color.

3.	 With the topmost item selected, choose 
Item>Actions and select Rollover. This is the 

most common place people have problems with 
rollovers. If the Item>Actions menu is greyed 
out at this stage, see the “Common Queries with 
Rollovers” at the end of this section for advice.

4.	 In the Actions palette (the “Images” window shows 
as default), click on one of the check marks in the 
“Normal” column to remove it and click once in 
the MouseOver column to create a check mark.

5.	 You can see which item will show for each state by 
clicking once on the bar at the top of each column.

Working with Freeway Actions

The above step-by-step creates the most simple rollover 
possible. If you want further help with rollovers, read 
the instructions earlier this guide in Tutorial 3.

Instead of duplicating items, we could also have 
copied and pasted the different elements of the 
rollover, edited them separately in different areas of 
the page and then aligned them into a stack using 
Freeway’s Align feature. Whichever route you take, the 
principle is still the same.

You can use any graphic item in Freeway as part of a 
rollover, regardless of its content.
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Rollover options in the Actions palette

In the step-by-step above we used only default settings 
with the exception of the placing of check marks 
in different columns. Let’s run through the various 
options available in the Actions palette—first we’ll 
look at the options in the Rollover Action’s “Images” 
window.

•	The Images window has a table-based layout—a 
list of all the items in the rollover on the left and a 
column for each of the Normal, MouseOver and 
Click states.

•	You don’t need to use all three states, many times 
you’ll use just Normal and MouseOver.

•	A check mark in an item’s row for a particular 
column signifies that the item will be visible in that 
state. Where there is no check mark, the item will 
be invisible. Click on a blank area of the table to 
generate a check mark, click on an check mark to 
remove it.

•	 If you want an item to display in all states—for 
instance a graphic text item displaying the name of a 
rollover hyperlink—you should check each column.

Now let’s look at the options in the Parameters 
window, which is a list of pop-up menus:

•	MouseOver: This 
pop-up controls the 
mouseover state. “Off” 
means there is no 
mouseover state, and 
“Items” means use the 
items specified for the 
mouseover state in the 
images window. You can 
also choose “Select”, 

which allows you to select a graphic from your 
computer’s hard drive for the mouseover state.

•	Click: This menu works in the same way as the 
MouseOver menu but for the Click state.

•	Restore: This pop-up menu controls whether the 
rollover restores back to the Normal state when 
the mouse is moved away from the rollover. “Yes” 
displays as default. If you set it to “No”, the image 
will only return to its Normal state when the page 
is revisited. Setting the menu to “Sticky” retains 
the MouseOver or Click state until you mouseover 
another rollover on the page.

•	Preload: By default, this pop-up menu is set to “Yes”, 
which means that all the graphics of the rollover will 
load into the browser’s cache before the rollover is 
displayed. This makes the transition from one state 
to another smoother as the graphics for each state 
don’t need to load when the transition is made.

•	Find Targets: A rollover can be used as a “trigger” 
for an “event”, which means that, for instance, 
moving your mouse over a rollover can make Target 
Images appear elsewhere on your page. This pop-up 
menu is only used when your page is a “frameset” 
and you need to control which frame the targets 
appear in.

•	Target Group: When using the Rollover as a trigger, 
you can set different groups of targets to be triggered 
when a different trigger is activated. Target Groups 
have color names (such as Indigo and Cobalt). Indigo 
is the default target group.

•	MouseOver #: When using a rollover as a trigger, 
this sets a specific target number (which corresponds 
to an item’s target number in the specific target’s 
Action dialog) to appear when the rollover is 
mouseovered.
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•	Click #: This menu works in the same way as the 

MouseOver # menu but sets a specific target number 
to be triggered when the rollover is clicked.

Common queries with rollovers

Softpress Support often gets queries from new users 
who can’t get their rollovers to work. Let’s look at some 
of these queries and their simple solutions:

•	Query: Why don’t the different elements of my 
rollover appear in the rollover Action dialog?

	 Solution 1: For rollovers to 
work, the elements must be 
set to “combine” with each 
other. Select each element 
in turn and make sure that 
Combine Graphics is 
checked in the General tab 
of the Inspector.

	 Solution 2: If you’re using 
Pro, you may have one or 
more of the elements of 
your rollover set as a layer. 
Select each element in turn 
and make sure that Layer is 
unchecked in the General 
tab of the Inspector—see 
screenshots on the right. 
This has probably happened 
because you have your CSS 
Layout button turned on (so 
it displays in blue).

•	Query: Why are items appearing in the rollover 
Action dialog that I don’t want for my rollover?

	 Solution: By default, Freeway will set all touching or 
overlapping graphic items to “combine”, so if your 
rollover items are on top of another graphic item, this 
will appear in the list of images in the rollover Actions 
palette along with any other graphic items combining 
with it. You need to select the background graphic 
item then uncheck the Combine Graphics checkbox 
in the General tab of the Inspector. The background 
graphic item will appear in the list but it will now be 
greyed out.

•	Query: Why does my normal image look OK in 
a browser, but when I mouseover the rollover 
it changes to the mouseover image and won’t 
change back?

	 Solution: You have Restore set to “No” in the 
Parameters tab of the rollover Actions palette. 
Change it to “Yes” so that the “Normal” image is 
restored when the mouse is moved away from the 
rollover.

For further information on rollovers, see the Using 
Freeway Actions guide.

The Target Image Action
Another commonly-used Action is the Target Image 
Action, which is used to make a specified image (or 
group of images) display when an event is triggered.

Target images were used with a rollover trigger in 
the Tutorials section of this guide, so here we’ll look at 
the basic principles of target images, how to set them 
up and also discuss common problems that new users 
have.

It’s worth pointing out that target images on their 
own don’t do anything. As their name suggests, they 
are simply the target of some other activity. Most often, 
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they will be used with rollovers which trigger specific 
images to display when the rollover is moused over. 
They can, however, be used in other ways, such as with 
a Page Action called Sequence Timer which is applied 
to a page containing a stack of target images to make 
them appear in a set sequence when the page is loaded.

In many ways, target images are set up in a very 
similar way to rollovers. Like rollovers, they are 
arranged in a stack and the Target Image Action palette 
is very similar to the Rollover Action in that it has 
Images and Parameters windows, the layout of which 
is table-based for the Images window and a list of pop-
up menus for the Parameters window. In the Images 
window, you place check marks in the columns of the 
image you want to display when that image’s number 
is triggered.

This Action is limited to a maximum number of 20 
images per target group (though an Action with an 
upper limit of 60 is available on ActionsForge).

Target Image options in the Actions palette

As stated earlier, the Images window of the target 
image Action is very similar to the rollover Action 
(see above). The main difference is that the columns 
represent trigger numbers rather than the states of a 
rollover. The Parameters window is also very similar. 
The first three pop-up menus are exactly the same as 
the Rollover Action, with the exception of the Restore 
pop-up having one extra option called “Toggle”. Toggle 
causes the target image to remain displayed until the 
trigger is activated again.

Beneath these are individual pop-ups for each image 
in the stack of target images (Image 1 to Image 20). 
When a trigger number is checked for a particular 
image in the Images menu, the pop-ups for these items 
will automatically display as “Items”.

The Image number corresponds to the MouseOver # 
and Click # settings in the rollover Actions pallete’s 
Parameters window.

If a trigger number is not set in the Images window, 
the pop-up will display as “Off”. These can, however, 
be set manually with these pop-ups.

In addition to “Items” and “Off”, there is a third 
option in the pop-up called “Select” which allows you 
to choose an image on your hard drive to display.

Common queries with target Actions

If you have problems with your targets, see the 
“Common queries” section on Rollovers mentioned 
earlier. 

New window Actions
There are three similar Actions which trigger a new 
window to open. 

•	Text Link to New Window is a Standalone Action 
that will put text on your page which will open a 
new browser window when clicked on.

•	Link to New Window is an Item Action which is 
applied to graphic items to trigger a new browser 
window to be opened when the item is clicked on. 

•	Pic in New Window is also an Item Action for 
graphic items, which will display a graphic in a new 
browser window when the graphic item is clicked on.

Text Link to New Window Action

A Standalone Action which can be drawn on the page 
after clicking on the Action tool on the tool bar and 
selecting Text Link to New Window.

This can be placed as a separate item on the page by 
choosing it from the menu with nothing else selected, 
or it can be placed in-flow within HTML text. As it is a 
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Standalone Action, the Action will already be applied 
when the item is drawn.

The Action will create a link from the text typed into 
the Action dialog which will open a specified page 
you’ve already created.

The options available in the Text Link to New 
Window Action dialog are:

•	Text: This is the text 
which will be displayed 
in the browser as a link. 
Clicking on the link in a 
browser will open a new 
window.

•	Window Name: The 
name used to identify 
the window in which 
the page is opened. 
If each link is given a 
different window name, 
a new window will be opened for each link. If you 
want all links to open in the same window each time, 
use the same window name for each link.

•	Auto Close: Used in conjunction with the Self 
Closing Pop-up Window Action, you can make the 
page close automatically when a new page is loaded 
into the browser window which opened the page.

•	Page: This is the page to be displayed in the new 
window. Choose the page you want from the list in 
the pop-up menu.

•	Width/Height: You need to specify the size, in 
pixels, of the new window.

•	Toolbar: This allows you to choose whether the new 
page displays with a browser tool bar.

•	Scrollbars: This allows you to choose whether the 
new page displays with scrollbars.

•	Resizable: Determines whether the new window will 
be resizable by the visitor to the web site.

•	Use Link: Used in conjunction with the Hyperlinks 
dialog, you can set this to “Yes” so that a new page 
appears in the main window and a new browser 
window is also displayed.

Link to New Window Action

This is an Item Action which can be applied to a 
graphic item by selecting it, choosing Item>Actions 
then selecting Link to New Window.

The options for the Link to New Window Action are 
exactly the same as the Text Link to New Window (see 
above), with the exception that there is no Text field.

Pic in New Window Action

This is another Item Action which can be applied to a 
graphic item by selecting it, choosing Item>Actions 
then selecting Pic in New Window.

Unlike the two previous new window Actions, this 
will only display a specified image in the new window. 
The chosen image will scale to fit the new window 
dimensions, and will scale up or down automatically 
when the window is resized.

The Pic in New Window Action does not have 
options for Text, Auto Close or Page, but there is an 
option called Image where you select the image you 
wish to display in the new window.

Download Actions
There are a few different Freeway Actions which make 
it very simple to have a download link on a page for 
visitors to click on to save a file to their computer. Each 
of the following download Actions will upload the 
linked file to the web server when you upload your site 
in Freeway.
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Link to PDF Action

A Standalone Action which can be drawn on the page 
after clicking on the Action tool on the tool bar and 
selecting Link to PDF.

This can be placed as a separate item on the page by 
choosing it from the menu with nothing else selected, 
or it can be placed in-flow within HTML text.

The Action will create a 
link from the text typed 
into the Action dialog 
which, when clicked in 
a browser, will download 
the linked PDF.

The options available 
for the Link to PDF Action are:

•	File: Use this pop-up menu to select the PDF file you 
want to offer for download.

•	 If Displayed: Some browsers have a  
plug-in which allows PDFs to be displayed in 
the browser window, although ultimately this is 
controlled by the visitor’s browser preferences. This 
pop-up menu gives options to use this function if 
the preferences allow it. In Place, the default option, 
will display the PDF in the current frame or window. 
Full Window loads the PDF into the entire browser 
window if you are using framesets. New Window 
opens a new window to display the PDF—this is 
recommended if you are using framesets.

•	Name: The text you type in here will be the linked 
text that will be added to your page.

Graphic Link to PDF Action

This Action has a very similar function to the Link to 
PDF Action, but it is applied to a graphic item rather 
than being a Standalone Action.

The options for the Graphic Link to PDF Action are 
the same as the Link to PDF Action, but it doesn’t have 
the Name field.

Link to File Action

A Standalone Action which can be drawn on the page 
after clicking on the Action tool on the tool bar and 
selecting Link to File.

This can be used as a separate item on the page by 
drawing it on a blank area of the page, or it can be 
placed in-flow within HTML text.

The Action will create a link on the text typed into 
the Action dialog which will start a download of the 
linked file when clicked on in the browser.

The options available for the Link to File Action are:

•	File: Use this pop-up menu to select the file you want 
to offer for download.

•	Name: The text you type in here will be the linked 
text on your page.

Graphic Link to File Action

This Action has a very similar function to the Link to 
File Action, but it is applied to a graphic item rather 
that being a Standalone Action.

The only option available for the Graphic Link to File 
Action is the File menu where you choose the file you 
want to offer for download.

Target Show/Hide Actions
There are two Actions which can show or hide page 
content when a rollover is triggered—one can show or 
hide an image, the other (which is Pro-only) can show 
or hide a layer on the page which contains a group of 
HTML and graphic items.
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Target Show/Hide Image Action

This is an item Action which is available in both 
Express and Pro. To apply it, select a graphic item 
you want to show or hide on the page, choose 
Item>Actions and select Target Show/Hide Image.

This Action needs to be used in conjunction with 
a trigger Action—for example, a rollover—so that it 
shows or hides the target 
image when its target 
number is set in the 
trigger Action. This works 
in a similar way to the 
Target Image Action cover 
earlier in this section and 
also in Tutorial 3.

The options for the 
Action are:

•	 Initially: Determines whether the image is visible 
when the page loads. The image is visible by default.

•	Restore: This pop-up menu controls whether the 
image restores back to the Normal state when the 
mouse is moved away from the rollover. “Yes” 
displays as default. If you set it to “No”, the image 
will only return to its Normal state when the page 
is revisited. “Toggle” causes the mouseover image to 
remain displayed until the mouse is moved over the 
rollover image again. Setting the Restore menu to 
“Sticky” retains the MouseOver or Click state until 
you mouseover another rollover.

•	Preload: By default, this pop-up menu is set to 
“Yes”, which means that the graphic will load into 
the browser’s cache before it is triggered so it displays 
instantly when the rollover is mouseovered.

•	Target group: When using the Rollover as a trigger, 
you can set different groups of target images to 

display when a particular trigger is mouseovered. 
Target Groups have color names (such as Indigo and 
Cobalt). Indigo is the default target group.

•	Target #: Sets the trigger number within the target 
group so the correct image displays when triggered.

Target Show/Hide Layer Action 

This Action behaves in a similar way to Target Show/
Hide Image, but it can be applied to a layer item on a 
page which contains many items.

This Action needs to be used in conjunction with a 
trigger, so that it shows or hides the target layer items 
when their target number is set as the MouseOver # 
and Click #.

The options available in the Target Show/Hide Layer 
Action dialog are the same as for the Target Show/Hide 
Image Action, except that there is no Preload option.

The Sequence Timer Action
This Action can display a simple, self-running photo 
gallery which shows a set of images in a specific order, 
changing to the next image after a given time setting.

The Sequence Timer Action is a Page Action, but 
it needs to be used in 
conjunction with the 
Target Image Action 
applied to a stack of 
target images which are 
used as the gallery of 
images.

With the stack of Target 
Images set up on the 
page, choose Page>Page 
Actions and select 
Sequence Timer. With 
no items selected on the 

Pro only
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page, the Actions palette will display the Sequence 
Timer Action.

Options available in the Sequence Timer Action 
dialog are:

•	Speed: This is the time interval between each trigger 
in the sequence (in thousandths of a second). The 
default is 500, which means an interval of half a 
second will pass between each trigger.

•	Target Group and Find Targets: These are the same 
as in the Rollover Action.

•	Trigger 1–20: These are the trigger numbers which 
correspond to the amount of Target Images in the 
stack on the page. If you have five Targets Images, 
Trigger numbers 1 to 5 should be set to “Yes”.

Note: Only one Sequence Timer Action can be applied 
to a page, even if a different target group is set.

Graphic Actions
Freeway offers many Actions which create complex 
effects for graphic used on your page. They never 
modify the original graphic, just the graphic that is 
output by Freeway when published.

The best way to see how they 
work is to experiment with 
them—just select a graphic item 
containing an imported graphic 
then choose Item>Action 
and select one of the graphic 
Actions. Here is a brief run-
down of what they all do:

•	Advanced Fade: Allows 
more control over fading 
effects than the standard Fade 
Action.

•	Blur: Blurs an image.
•	Chroma Key: Creates transparency using a color in 

an image.
•	Hue Rotate: Allows colors to be changed by rotating 

them through the hue spectrum.
•	 Impress: Simulates raised and lowered areas using 

lightness information in the image.
•	Linear Blur: Blurs an image along a vertical or 

horizontal axis.
•	Saturate: Controls the amount of color in an image.
•	Sharpen: Sharpens an image.
•	Solarize: Applies solarizing effects to an image.
•	Duotone: Applies duotone or tritone effects.
•	Fade: Applies image fade effects.
•	Photo Frame: Applies graphic edge effects.
•	Photo Magic: Adjusts image color, brightness and 

contrast settings with sliders.
•	Posterize: Applies posterizing effects.
•	Scan Lines: Applies image scan lines on the image.

Note: The above graphic Actions will have no effect on 
a graphic item drawn on the page in Freeway—they 
will only work with imported graphics. 

•	Fill Master: Generates filled, framed, shadowed and 
glowing shapes. A graphic item with the Fill Master 
Action applied can also use the above graphic Action 
effects, although some may may conflict with the Fill 
Master effects.

•	Buttons: Generates different types of button shapes. 
This Action only works with Freeway-created graphic 
items.

•	Watermark: Places a watermark on an image using 
an external file. This works with both Freeway-
created graphic items and imported graphics.
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Glossary of internet and Freeway terms

Action  A Freeway Action is a  
plug-in which can be installed into 
your program to add functionality 
to an item, page, folder or site. An 
Action adds complex HTML or 
JavaScript code which is modified 
through easy-to-use dialogs. 

Alt-click  See Option-/Alt-click.

Alt tags  Information used to give a 
text description to graphics which 
can be indexed by search engines. 
Alt tags can be read by screen readers 
and also define the text shown 
when graphics display is disabled or 
when a site is viewed on a handheld 
device.

Anchor  The destination of a link, 
often to a particular point of a page 
(such as back to the top of a page 
or to a section header of a long 
page), rather than just a hyperlink to 
another page.

Animated GIF file  See GIF file.

Background image  A graphic 
which has been selected to use as 
the background for a page or item.

Backup file  A file located in the 
same folder as your Freeway file, 
which is the previously saved 
version of your current Freeway 
file. If your Freeway file becomes 
corrupted, you can recover your 
work from the last saved version by 
opening your backup file. Every time 
a Freeway file is saved, the backup 
file is updated to the previously 
saved version.

Browser  See Web Browser.

Cascading Style Sheets  See CSS.

Case sensitive  Upper or lower case 
characters must be used as specified.

Cache  A facility whereby a web 
browser stores copies of graphics and 
web pages on a user’s hard disk to 
speed up loading times. Occasionally 
this needs to be cleared to see 
changes on an updated site.

Child item/Children  HTML and 
graphic items can be ‘nested’ inside 
each other, which makes the nested 
item a child and the item it is within 
the ‘parent’.

Click  A standard mouse click 
(using your mouse button with no 
special keys held down). Clicking 

the mouse when holding down a 
keyboard special key (see Control-
click, Option/Alt-click and Shift-
click) changes the functionality of 
the click. See also Click and drag, 
Double-click and Right-click.

Click and drag  To click once on an 
item and move the mouse with the 
button still held down.

Control-click  To click on an item 
with the standard mouse button 
while holding down the Control 
key. In Freeway, this gives access to 
contextual menus. This is usually 
the same as clicking the right mouse 
button on a two-button mouse.

CSS (Cascading Style Sheets)  A 
W3C recommended language for 
defining page and text styles (such 
as font, size, color, spacing, etc.) as 
well as layout.

Dot Mac  See MobileMe.

Double-click  To click on an item 
twice with the standard mouse 
button in quick succession. Double-
clicking on a word selects the whole 
word.

Download  To transfer files or data 
from a remote computer or server to 
a user’s computer. The opposite of 
‘upload’.

This glossary explains the key terms 
used in this Getting Started guide 
and the Freeway Reference.

It is also intended to be a reference 
for new user’s who find the jargon 
and terminology of the internet is a 
barrier to learning Freeway. 
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Drag and drop  A feature in many 
Mac applications where you can 
click and drag a file from one page 
or program to another. In Freeway, 
you can drag a photo from iPhoto 
onto your page, for instance.

Dynamic  A term used to describe 
anything which shows change or 
activity. A dynamic effect can be a 
rollover or a target image.

E-commerce site  An online shop 
which uses a shopping cart and 
secure payment facility. Freeway 
ships with a suite of Actions to make 
setting up an e-commerce site a 
simple operation.

Encryption  Altering information to 
make it unreadable by unauthorized 
parties.

Firewall  A hardware or software 
barrier which acts as a security filter 
by restricting unauthorized access 
to your network. Most often used 
between the user’s computer and the 
internet.

Flash file  A common vector-based 
multimedia format used on the web 
to create animation or complex 
dynamic effects.

Form  See HTML form.

Frames/Frameset  A frameset is a 
web page which has two or more 
frames, where one or more frames 
can be set to display content from 
different web pages.

FTP (File Transfer Protocol)  The 
most common method of uploading 
data to a web server.

GIF (Graphics Interchange 
Format) file  A common file format 
for graphics used on the web. GIFs 
are limited to 256 colors and can 
support transparency. They are best 
used for graphics with solid colors. 
Animated GIFs are files which play a 
sequence of individual images giving 
the impression of animation.

Graphic item  An item drawn 
on your Freeway page using the 
Graphic tool. A graphic item is a 
holder for images or graphic text on 
your page.

Graphic text  Double-clicking inside 
a graphic item in Freeway allows 
you to type graphic text in any font 
installed on your computer. Effects 
can be applied  
to graphic text while leaving your 
text fully editable. Graphic text 
won’t be indexed by search engines, 
can’t be copied in a browser or read 
by computer screen readers, etc.

Hex or Hexadecimal value 
Colors can be represented as a ‘hex 
value’—a value containing six letters 
or numbers.

Home Page  Usually the top-level 
page of a web site. Unless an intro 
page has been set, this will be the 
default page displayed when you 
visit a web site. A home page is 
usually the file called ‘index.html’.

Host  See Web host.

HTML (Hypertext Markup 
Language)  A simple computer 
language, specially written for the 
web.

HTML editor  A program which 
edits HTML code. Freeway is not 
an HTML editor—it is an HTML 
generator which generates the code 
when a file is published. To make 
changes to your site you edit the 
pages in Freeway and republish to 
generate the new code.

HTML Form  A page, or area of a 
page, with fields where content 
typed in by the visitor is captured 
when the form is submitted.

HTML item  An item drawn on your 
Freeway page using the HTML tool. 
An HTML item is a holder for HTML 
text and other items, such as check 
boxes, form fields, etc., on your 
page.

HTML text  Double-clicking inside 
an HTML item in Freeway allows 
you to type HTML text. HTML text 
requires the visitor to have the font 
you use on your site to display the 
font correctly, so it is advisable to 
use only web-safe fonts. HTML text 
can be indexed by search engines, 
can be copied in a browser and 
is readable by computer speech 
programs.

HTTP (Hyper Text Transfer 
Protocol)   The standard set of rules 
used for transferring files on the 
internet.
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Hyperlink   A graphic or text link 

which, when clicked, will cause the 
browser to show a different location 
on the web.

Internet browser  See Web browser.

Index page  See Home page.

JavaScript  The most popular 
client-side scripting language on the 
internet, developed by Netscape.

JPEG (Joint Photographic 
Expert Group) or JPG file  A 
common file format for graphics 
and the most popular format for 
photos on the web. JPEGs support 
millions of colors but don’t support 
transparency. They are best used 
for graphics with continuous tones, 
such as photos.

Layer  A type of item available in 
Freeway Pro which uses CSS to 
position the item exactly.

Link map  A Freeway Pro-only 
feature which will display a graphic 
representation of how the pages, 
items and hyperlinks of your site 
interact.

mailto:  An external protocol which 
creates an email hyperlink. The 
hyperlink makes a visitor’s default 
email program launch when clicked 
on.

Map area  An area drawn with 
the map area tool which can be 
hyperlinked. Most commonly used 
to define areas to be hyperlinked on 
top of a graphic.

Master page  A special page which 
can be used to display commonly 
used items on every page based  
on that master. Changes to the 
master page will be automatically 
reflected on all pages based on that 
master.

Media folder  A folder which sits in 
the same folder as your Freeway file 
(if it was created from a template), 
where you can place any media files 
you’ve already prepared for your 
site.

Meta tags  Information stored in 
the HTML code of a web page, 
containing description and 
keywords which can be indexed by 
search engines.

MOV file  A common format for 
movie files with audio used on 
the web. MOV files use Apple’s 
QuickTime to play multimedia files 
through a browser plug-in.

MP3 File  A common format for 
audio files used on the web.

MPEG (Moving Picture Expert 
Group) file  A common format for 
movie files with audio used on the 
web.

Multimedia  A term used to describe 
a project which combines text with 
pictures, video or audio.

Navigation bar  A group of rollovers 
on a page, usually displayed as a row 
or column to aid navigation of your 
site. Freeway’s CSS Menu Action is a 
quick and simple method of creating 

a drop-down-and-fly-out navigation 
bar.

MySQL  A common open source 
database used on the web.

Online shop  See E-commerce.

Option-click  To click on an item 
with the standard mouse button 
while holding down the Option key 
(sometimes the O key or called 
Alt). In Freeway, you can change the 
names of pages in the site panel by 
Option-clicking on a page’s name, 
for instance.

Parent  An item in which other 
items are ‘nested’. Nested items are 
known as ‘child items’ or ‘children’.

PDF (Portable Document 
Format) file  A common cross-
platform file format for documents 
containing text, graphics and 
hyperlinks in which fonts can 
be embedded so they display 
exactly as they were created. PDFs 
can be displayed in a browser or 
downloaded and opened using 
Adobe’s Acrobat Reader or Apple’s 
Preview.

Perl (Practical Extraction and 
Reporting Language)  A common 
scripting language used on the web. 
Most often used on Unix servers.

PHP (PHP: Hypertext 
Preprocessor)  A common 
scripting language, processed on 
the server, allowing pages to be 
generated based on user requests.
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Pixel  A common unit of measure in 
web design. Pixels are the individual 
points of information on a computer 
screen, so the resolution of the 
screen dictates the actual physical 
size.

Plug-in  An extra application built 
in or added to web browsers to 
give extra functionality such as 
displaying different types of files.

PNG (Portable Network 
Graphics) file  A common format 
for graphics used on the web. PNGs 
support millions of colors and 
transparency, and can be used for 
photos or graphics of solid color.

Pop-up window  A window which 
appears when a rollover is triggered 
on mouseover or by clicking.

Preview  Viewing a page to see 
how it looks in a browser. Freeway 
offers a quick method by clicking 
on the Preview button in the main 
interface, but the most reliable 
method is to preview the page in a 
web browser.

QuickTime  A technology used to 
embed multimedia content into a 
web page and to display it in a web 
browser.

Real Audio file  A common format 
for audio files used on the web.

Real Video file  A common format 
for movie files with audio used on 
the web.

Right-click  To click on an item 
with the right mouse button on a 

two-button or multi-button mouse. 
This is the same as Control-clicking 
on an item with a single-button 
mouse. In Freeway, this gives access 
to contextual menus.

Rollover  A text rollover or graphic 
which triggers a change of color 
or other defined function on 
mouseover or when clicked.

Script  A text file written in a 
simple computer language (such 
as JavaScript) in the form of a 
collection of statements which 
invokes a behavior or group of 
behaviors.

Search engine  A program used to 
search and index pages on the web. 
Common search engines are Google 
and Yahoo.

Shockwave  A technology used to 
embed multimedia content into a 
web page.

SIT (StuffIt) file  A common format 
for compressing a file for Mac 
computers to be downloaded over 
the internet, now less common than 
a Zip file.

SQL (Structured Query 
Language)  A language used for 
interacting with relational databases, 
for example MySQL.

Server-side technology 
Functionality of a web site which 
can’t be achieved by the design 
and coding of the site on the user’s 
computer. Server-side technology 
requires your server to support 

external scripting libraries and other 
facilities. You will need to check to 
see if your server offers this support.

Shift-click  To click on an item with 
the standard mouse button while 
holding down the Shift key. In 
Freeway, you select multiple items 
by Shift-clicking on items one at a 
time.

Streaming  Receiving audio and 
video files over the internet so the 
user can view the file as it is being 
transferred.

SVG (Scalable Vector Graphic) 
file  An XML-based graphic format 
which can be scaled without the 
image becoming pixelated.

Target image  A graphic or photo 
which displays on a page when a 
rollover triggers it to do so.

tel:  An external protocol which 
creates an telephone hyperlink for 
use with mobile communication 
devices such as the iPhone. The 
hyperlink makes the device call the 
designated phone number.

Upload  To transfer files or data from 
the user’s computer to a remote 
computer or server. The opposite of 
‘download’.

URL (Uniform Resource 
Locator)  The address of a resource 
(for instance a web page), commonly 
entered into the address bar of a 
browser (such as  
http://www.softpress.com).
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W3C (World Wide Web 
Consortium) The organization 
responsible for managing standards 
for the World Wide Web.

Web address  See URL.

Web Applet  A small application 
which is downloaded from the web 
and run on the user’s computer.

Web browser  A program used to 
display web pages, such as Safari, 
Firefox or Internet Explorer.

Web form  See HTML Form.

Web host  The company that hosts 
your web site and to whose server 
you upload your site files to.

Web-safe color  Modern computer 
screens can display millions of 
colors, but color accuracy on older 
screens and older web browsers can 
only be guaranteed by using the list 
of 216 web-safe colors.

Web-safe font  Fonts on your web 
site will only display correctly if the 
visitor has the same font loaded on 
their computer. Most visitors will 
have the ‘core fonts’ loaded, but the 
only fonts guaranteed to be web-safe 
are the CSS generic font families of 
serif, sans-serif, etc., which Freeway 
will automatically ask a browser to 
use if any core font is not found.

Web server  A computer which is set 
up to deliver services or information 
stored on its hard disk to other 
computers, such as web content to a 
user’s web browser.

Windows Media file  A common 
format for audio and video files used 
on the web. Windows Media files 
usually have a suffix of either .wma 
(for audio files) or .wmv (for video 
files).

WinZip file  See Zip file.

WMA file  See Windows Media file.

WMV file  See Windows Media file.

WML (Wireless Markup 
Language)  A language used for 
viewing web data on hand held 
devices, based on a modified version 
of HTML.

WWW (World Wide Web)  The 
global network of computers linked 
to the internet allowing transfer of 
data using HTTP.

WYSIWYG (What You See Is 
What You Get)  A term used 
to describe how a web site being 
designed on-screen appears exactly 
as it will appear on the web. Freeway 
is a WYSIWYG program.

XHTML (Extensible Hypertext 
Markup Language)  The latest, 
version of HTML, developed by 
W3C.

Zip file  A common format used 
to compress a file ready for 
downloading over the internet. 
Mac computers automatically 
decompress (unzip) Zip files after 
downloading.


